summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-01-28 19:51:45 +0000
committerMike Gilbert <floppym@gentoo.org>2012-01-28 19:51:45 +0000
commit9d5529768f8f738ac139257ba67147a32e363b1f (patch)
treedeff49bab55ba0b04cae81a886b3d960c293741b /dev-python/pyopencl/pyopencl-2011.2-r1.ebuild
parentalpha/arm/ia64/m68k/s390/sh/sparc/x86 stable wrt #401089 (diff)
downloadgentoo-2-9d5529768f8f738ac139257ba67147a32e363b1f.tar.gz
gentoo-2-9d5529768f8f738ac139257ba67147a32e363b1f.tar.bz2
gentoo-2-9d5529768f8f738ac139257ba67147a32e363b1f.zip
Prepare for PYTHON_ABI-versioned Boost Python libraries in Boost 1.48. Delete old version. Patch by Arfrever.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyopencl/pyopencl-2011.2-r1.ebuild')
-rw-r--r--dev-python/pyopencl/pyopencl-2011.2-r1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/pyopencl/pyopencl-2011.2-r1.ebuild b/dev-python/pyopencl/pyopencl-2011.2-r1.ebuild
new file mode 100644
index 000000000000..b49144ddb5f1
--- /dev/null
+++ b/dev-python/pyopencl/pyopencl-2011.2-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopencl/pyopencl-2011.2-r1.ebuild,v 1.1 2012/01/28 19:51:45 floppym Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython *-pypy-*"
+
+inherit distutils
+
+DESCRIPTION="Python wrapper for OpenCL"
+HOMEPAGE="http://mathema.tician.de/software/pyopencl http://pypi.python.org/pypi/pyopencl"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples opengl"
+
+RDEPEND=">=dev-libs/boost-1.48[python]
+ dev-python/numpy
+ dev-python/pytools
+ virtual/opencl"
+DEPEND="${RDEPEND}"
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+
+src_configure()
+{
+ configuration() {
+ local myconf=()
+
+ if use opengl; then
+ myconf+=(--cl-enable-gl)
+ fi
+
+ "$(PYTHON)" configure.py \
+ --boost-compiler=gcc \
+ --boost-python-libname=boost_python-${PYTHON_ABI}-mt \
+ --boost-thread-libname=boost_thread-mt \
+ --no-use-shipped-boost \
+ "${myconf[@]}"
+ }
+ python_execute_function -s configuration
+}
+
+src_install()
+{
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
+
+pkg_postinst()
+{
+ distutils_pkg_postinst
+ if use examples; then
+ elog "Some of the examples provided by this package require dev-python/matplotlib."
+ fi
+}