summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-02-26 06:33:12 +0000
committerIan Delaney <idella4@gentoo.org>2013-02-26 06:33:12 +0000
commit840091437fb196fd68a77470ae4db07736f54138 (patch)
tree9a6035107f0f5e5b7b280226a2999561a5ce4c2a /dev-python/pytest
parentExclude tests the right way. (diff)
downloadgentoo-2-840091437fb196fd68a77470ae4db07736f54138.tar.gz
gentoo-2-840091437fb196fd68a77470ae4db07736f54138.tar.bz2
gentoo-2-840091437fb196fd68a77470ae4db07736f54138.zip
unicode.patch adjusted consequent to upstream's partial update to tox.ini, IUSE test added, fixes Bug #458418
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/ChangeLog7
-rw-r--r--dev-python/pytest/files/pytest-2.3.4-unicode.patch17
-rw-r--r--dev-python/pytest/pytest-2.3.4.ebuild4
3 files changed, 8 insertions, 20 deletions
diff --git a/dev-python/pytest/ChangeLog b/dev-python/pytest/ChangeLog
index 405839677e20..ad30534911d4 100644
--- a/dev-python/pytest/ChangeLog
+++ b/dev-python/pytest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pytest
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.46 2013/02/13 13:09:54 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.47 2013/02/26 06:33:12 idella4 Exp $
+
+ 26 Feb 2013; Ian Delaney <idella4@gentoo.org>
+ files/pytest-2.3.4-unicode.patch, pytest-2.3.4.ebuild:
+ unicode.patch adjusted consequent to upstream's partial update to tox.ini,
+ IUSE test added, fixes Bug #458418
14 Feb 2013; Ian Delaney <idella4@gentoo.org>
+files/pytest-2.3.4-unicode.patch, pytest-2.3.4.ebuild:
diff --git a/dev-python/pytest/files/pytest-2.3.4-unicode.patch b/dev-python/pytest/files/pytest-2.3.4-unicode.patch
index 9925f277dc97..a23bf55cfc4f 100644
--- a/dev-python/pytest/files/pytest-2.3.4-unicode.patch
+++ b/dev-python/pytest/files/pytest-2.3.4-unicode.patch
@@ -32,20 +32,3 @@ diff -ur pytest-2.3.4.orig/testing/python/metafunc.py pytest-2.3.4/testing/pytho
def test_addcall_and_parametrize(self):
-diff -ur pytest-2.3.4.orig/tox.ini pytest-2.3.4/tox.ini
---- tox.ini 2012-11-20 14:07:28.000000000 +0800
-+++ tox.ini 2013-02-14 10:04:26.066826443 +0800
-@@ -50,6 +50,13 @@
- commands=py.test --doctest-modules _pytest
- deps=
-
-++[testenv:py32]
-+deps=
-+ :pypi:nose
-+
-+[testenv:py33]
-+deps=
-+ :pypi:nose
-
- [testenv:doc]
- basepython=python
diff --git a/dev-python/pytest/pytest-2.3.4.ebuild b/dev-python/pytest/pytest-2.3.4.ebuild
index 782ea5a52b83..b7ed6c753431 100644
--- a/dev-python/pytest/pytest-2.3.4.ebuild
+++ b/dev-python/pytest/pytest-2.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.3.4.ebuild,v 1.3 2013/02/13 13:09:54 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.3.4.ebuild,v 1.4 2013/02/26 06:33:12 idella4 Exp $
EAPI="5"
@@ -14,7 +14,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc"
+IUSE="doc test"
# When bumping, please check setup.py for the proper py version
PY_VER="1.4.12"