summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-08-02 02:14:13 +0000
committerMike Gilbert <floppym@gentoo.org>2013-08-02 02:14:13 +0000
commitfddf3c4b8dcfcc91bc05fb6f5d5eee6c97ae3a8b (patch)
tree44ad2caa7abf5ba08ade0ca0e586bb705f2ca88f /dev-python/python-debian
parentx86 stable wrt bug #470416 (diff)
downloadgentoo-2-fddf3c4b8dcfcc91bc05fb6f5d5eee6c97ae3a8b.tar.gz
gentoo-2-fddf3c4b8dcfcc91bc05fb6f5d5eee6c97ae3a8b.tar.bz2
gentoo-2-fddf3c4b8dcfcc91bc05fb6f5d5eee6c97ae3a8b.zip
Version bump. Convert to distutils-r1 and enable python3 support.
(Portage version: 2.2.0_alpha191/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/python-debian')
-rw-r--r--dev-python/python-debian/ChangeLog11
-rw-r--r--dev-python/python-debian/python-debian-0.1.21_p2.ebuild50
2 files changed, 58 insertions, 3 deletions
diff --git a/dev-python/python-debian/ChangeLog b/dev-python/python-debian/ChangeLog
index 9b9df654dd4d..8b70ec60af31 100644
--- a/dev-python/python-debian/ChangeLog
+++ b/dev-python/python-debian/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-debian
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-debian/ChangeLog,v 1.3 2011/09/09 05:05:44 floppym Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-debian/ChangeLog,v 1.4 2013/08/02 02:14:13 floppym Exp $
+
+*python-debian-0.1.21_p2 (02 Aug 2013)
+
+ 02 Aug 2013; Mike Gilbert <floppym@gentoo.org>
+ +python-debian-0.1.21_p2.ebuild:
+ Version bump. Convert to distutils-r1 and enable python3 support.
09 Sep 2011; Mike Gilbert <floppym@gentoo.org> python-debian-0.1.21.ebuild:
Tests require app-arch/dpkg
@@ -13,4 +19,3 @@
08 Sep 2011; Mike Gilbert <floppym@gentoo.org> +python-debian-0.1.21.ebuild,
+metadata.xml:
New package for bug 356129
-
diff --git a/dev-python/python-debian/python-debian-0.1.21_p2.ebuild b/dev-python/python-debian/python-debian-0.1.21_p2.ebuild
new file mode 100644
index 000000000000..931e4e049a4b
--- /dev/null
+++ b/dev-python/python-debian/python-debian-0.1.21_p2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-debian/python-debian-0.1.21_p2.ebuild,v 1.1 2013/08/02 02:14:13 floppym Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_{6,7},3_{1,2,3}} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python modules to work with Debian-related data formats"
+HOMEPAGE="http://packages.debian.org/sid/python-debian"
+MY_PV="${PV/_p/+nmu}"
+SRC_URI="mirror://debian/pool/main/${P:0:1}/${PN}/${PN}_${MY_PV}.tar.gz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( app-arch/dpkg )"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ sed -e "s/__CHANGELOG_VERSION__/${MY_PV}/" setup.py.in > setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ "${PYTHON}" lib/debian/doc-debtags > README.debtags || die
+}
+
+python_test() {
+ pushd tests > /dev/null || die
+ local t
+ for t in test_*.py ; do
+ "${PYTHON}" "${t}" || die "Testing failed with ${EPYTHON}"
+ done
+ popd > /dev/null || die
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/ )
+ distutils-r1_python_install_all
+}