summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2011-09-01 15:41:47 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2011-09-01 15:41:47 +0000
commit545ab13089f4014e17e9ef2248ecaa76a2085af3 (patch)
tree71a141d3ec60de1678c0164e88b419154fbd765f /dev-python/python-gflags/python-gflags-1.6.ebuild
parentVersion bump. (diff)
downloadgentoo-2-545ab13089f4014e17e9ef2248ecaa76a2085af3.tar.gz
gentoo-2-545ab13089f4014e17e9ef2248ecaa76a2085af3.tar.bz2
gentoo-2-545ab13089f4014e17e9ef2248ecaa76a2085af3.zip
Version bump.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/python-gflags/python-gflags-1.6.ebuild')
-rw-r--r--dev-python/python-gflags/python-gflags-1.6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/python-gflags/python-gflags-1.6.ebuild b/dev-python/python-gflags/python-gflags-1.6.ebuild
new file mode 100644
index 000000000000..35537a73cd7e
--- /dev/null
+++ b/dev-python/python-gflags/python-gflags-1.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-gflags/python-gflags-1.6.ebuild,v 1.1 2011/09/01 15:41:47 nelchael Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Google's Python argument parsing library."
+HOMEPAGE="http://code.google.com/p/python-gflags/"
+SRC_URI="http://python-gflags.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+PYTHON_MODNAME="gflags.py"
+
+src_prepare() {
+ distutils_src_prepare
+ sed -e 's/data_files=\[("bin", \["gflags2man.py"\])\]/scripts=\["gflags2man.py"\]/' -i setup.py
+}