summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-03-12 08:47:21 +0000
committerIan Delaney <idella4@gentoo.org>2013-03-12 08:47:21 +0000
commit207ecf75998e4f74b4ee6d42eb22948911df102a (patch)
tree62e540bdbcf090ae34bc0d7dd98a27951416d835 /dev-python/python-gtkmvc/python-gtkmvc-1.99.1.ebuild
parentInclude content of myzathuraconf also for testsuite wrt #454666 by Diego Elio... (diff)
downloadgentoo-2-207ecf75998e4f74b4ee6d42eb22948911df102a.tar.gz
gentoo-2-207ecf75998e4f74b4ee6d42eb22948911df102a.tar.bz2
gentoo-2-207ecf75998e4f74b4ee6d42eb22948911df102a.zip
bump
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/python-gtkmvc/python-gtkmvc-1.99.1.ebuild')
-rw-r--r--dev-python/python-gtkmvc/python-gtkmvc-1.99.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/python-gtkmvc/python-gtkmvc-1.99.1.ebuild b/dev-python/python-gtkmvc/python-gtkmvc-1.99.1.ebuild
new file mode 100644
index 000000000000..f2d4e804ef03
--- /dev/null
+++ b/dev-python/python-gtkmvc/python-gtkmvc-1.99.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-gtkmvc/python-gtkmvc-1.99.1.ebuild,v 1.1 2013/03/12 08:47:21 idella4 Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="model-view-controller (MVC) implementation for pygtk"
+HOMEPAGE="http://pygtkmvc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pygtkmvc/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND=">=dev-python/pygtk-2.24.0"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ dodoc README
+ use doc && dohtml -r docs/_build/html/
+
+ if use examples; then
+ docompress -x usr/share/doc/${P}/examples/
+ insinto usr/share/doc/${P}/
+ doins -r examples/
+ fi
+}