summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2014-09-27 20:16:02 +0000
committerAlex Brandt <alunduil@gentoo.org>2014-09-27 20:16:02 +0000
commit324e4fe6d68025c84404ad01ae48c657f9ec1ce5 (patch)
tree1d5e8ca3c07a0335b6007af728e12a5b11ea3b68 /dev-python/python-keystoneclient/python-keystoneclient-0.11.1.ebuild
parentfix testsuite by removing .testrepository between runs (diff)
downloadgentoo-2-324e4fe6d68025c84404ad01ae48c657f9ec1ce5.tar.gz
gentoo-2-324e4fe6d68025c84404ad01ae48c657f9ec1ce5.tar.bz2
gentoo-2-324e4fe6d68025c84404ad01ae48c657f9ec1ce5.zip
bump version to 0.11.1
Also added python3_3 target. (Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key 92FEA28B)
Diffstat (limited to 'dev-python/python-keystoneclient/python-keystoneclient-0.11.1.ebuild')
-rw-r--r--dev-python/python-keystoneclient/python-keystoneclient-0.11.1.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/python-keystoneclient/python-keystoneclient-0.11.1.ebuild b/dev-python/python-keystoneclient/python-keystoneclient-0.11.1.ebuild
new file mode 100644
index 000000000000..5f454143a540
--- /dev/null
+++ b/dev-python/python-keystoneclient/python-keystoneclient-0.11.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-keystoneclient/python-keystoneclient-0.11.1.ebuild,v 1.1 2014/09/27 20:16:02 alunduil Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Client Library for OpenStack Identity"
+HOMEPAGE="https://github.com/openstack/python-keystoneclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-linux ~x86 ~x86-linux"
+IUSE="examples test"
+
+# NOTE: docs to not install due to pbr configuration issues
+
+# NOTE: dev-python/discover not actually used
+# dev-python/discover[${PYTHON_USEDEP}]
+
+CDEPEND="
+ >=dev-python/pbr-0.6[${PYTHON_USEDEP}]
+ !~dev-python/pbr-0.7[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
+ >=dev-python/hacking-0.8[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.9[${PYTHON_USEDEP}]
+ >=dev-python/keyring-2.1[${PYTHON_USEDEP}]
+ !~dev-python/keyring-3.3[${PYTHON_USEDEP}]
+ >=dev-python/lxml-2.3[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ >=dev-python/mox3-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/oauthlib-0.6[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pycrypto-2.6[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testresources-0.2.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.34[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.2.3[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.9[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.12[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.2.1[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.7.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.0.0[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/.)
+
+ distutils-r1_python_install_all
+}