summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-14 17:14:08 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-14 17:14:08 +0000
commit5cbfd18851d0c3bc02fdc46401ec716f916db185 (patch)
treeccceb73fc3659b49915a7e1647960fb318e2a9a8 /dev-python/reportlab
parentDrop old version. (diff)
downloadgentoo-2-5cbfd18851d0c3bc02fdc46401ec716f916db185.tar.gz
gentoo-2-5cbfd18851d0c3bc02fdc46401ec716f916db185.tar.bz2
gentoo-2-5cbfd18851d0c3bc02fdc46401ec716f916db185.zip
Delete older ebuilds.
Diffstat (limited to 'dev-python/reportlab')
-rw-r--r--dev-python/reportlab/files/2.1-test_fix.patch12
-rw-r--r--dev-python/reportlab/files/2.1-test_no_network.patch14
-rw-r--r--dev-python/reportlab/files/2.1-tests_report_failure.patch26
-rw-r--r--dev-python/reportlab/reportlab-2.1.ebuild72
-rw-r--r--dev-python/reportlab/reportlab-2.3.ebuild81
5 files changed, 0 insertions, 205 deletions
diff --git a/dev-python/reportlab/files/2.1-test_fix.patch b/dev-python/reportlab/files/2.1-test_fix.patch
deleted file mode 100644
index 800102d3e1e6..000000000000
--- a/dev-python/reportlab/files/2.1-test_fix.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur reportlab_2_1.orig/reportlab/test/test_platypus_pleaseturnover.py reportlab_2_1/reportlab/test/test_platypus_pleaseturnover.py
---- reportlab_2_1.orig/reportlab/test/test_platypus_pleaseturnover.py 2007-06-23 10:28:17.000000000 +0200
-+++ reportlab_2_1/reportlab/test/test_platypus_pleaseturnover.py 2007-06-23 10:28:45.000000000 +0200
-@@ -113,7 +113,7 @@
- pto.alignment = TA_RIGHT
- pto.fontSize -= 1
- def ColorParagraph(c,text,style):
-- return Paragraph('<para color=%s>%s</para>' % (c,text),style)
-+ return Paragraph('<para color="%s">%s</para>' % (c,text),style)
-
- def ptoblob(blurb,content,trailer=None,header=None, story=story, H1=H1):
- if type(content) not in (type([]),type(())): content = [content]
diff --git a/dev-python/reportlab/files/2.1-test_no_network.patch b/dev-python/reportlab/files/2.1-test_no_network.patch
deleted file mode 100644
index d3b6548362ab..000000000000
--- a/dev-python/reportlab/files/2.1-test_no_network.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- test/test_lib_utils.py 2008-05-13 14:57:23.350829336 +0300
-+++ test/test_lib_utils.py 2008-05-13 14:57:33.962839567 +0300
-@@ -95,11 +95,6 @@
- from reportlab.lib.utils import open_and_read
- b = open_and_read('file:../docs/images/Edit_Prefs.gif')
-
-- def test9(self):
-- "test open and read of an http: URL"
-- from reportlab.lib.utils import open_and_read
-- b = open_and_read('http://www.reportlab.com/rsrc/encryption.gif')
--
- def test10(self):
- "test open and read of a simple relative file"
- from reportlab.lib.utils import open_and_read, getStringIO
diff --git a/dev-python/reportlab/files/2.1-tests_report_failure.patch b/dev-python/reportlab/files/2.1-tests_report_failure.patch
deleted file mode 100644
index c6c65dd868a4..000000000000
--- a/dev-python/reportlab/files/2.1-tests_report_failure.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- reportlab_2_1/reportlab/test/runAll.py.orig 2007-05-24 13:08:05.000000000 +0200
-+++ reportlab_2_1/reportlab/test/runAll.py 2007-06-21 20:38:12.000000000 +0200
-@@ -59,7 +59,7 @@
- cleanOnly = '--clean' in sys.argv
- if not cleanOnly:
- testSuite = makeSuite(folder,nonImportable=NI,pattern=pattern+(not haveSRC and 'c' or ''))
-- unittest.TextTestRunner().run(testSuite)
-+ result = unittest.TextTestRunner().run(testSuite)
- if haveSRC: cleanup(folder,patterns=('*.pyc','*.pyo'))
- if not cleanOnly:
- if NI:
-@@ -67,6 +67,7 @@
- for f,tb in NI:
- print 'file: "%s"\n%s\n' % (f,string.join(tb,''))
- printLocation()
-+ return result
-
- def mainEx():
- '''for use in subprocesses'''
-@@ -90,4 +91,5 @@
- return '\nFAILED' in outerr
-
- if __name__ == '__main__': #noruntests
-- main()
-+ if not main().wasSuccessful():
-+ sys.exit(-1)
diff --git a/dev-python/reportlab/reportlab-2.1.ebuild b/dev-python/reportlab/reportlab-2.1.ebuild
deleted file mode 100644
index 8b50977ca369..000000000000
--- a/dev-python/reportlab/reportlab-2.1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/reportlab/reportlab-2.1.ebuild,v 1.9 2008/07/17 18:59:13 aballier Exp $
-
-NEED_PYTHON=2.4
-
-inherit distutils versionator
-
-MY_PV="$(replace_all_version_separators _)"
-
-DESCRIPTION="Tools for generating printable PDF documents from any data source."
-HOMEPAGE="http://www.reportlab.org/"
-SRC_URI="http://www.reportlab.org/ftp/ReportLab_${MY_PV}.tgz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="doc examples"
-
-DEPEND="sys-libs/zlib
- dev-python/imaging
- media-fonts/ttf-bitstream-vera"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${PN}_${MY_PV}/${PN}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${PV}-tests_report_failure.patch"
- epatch "${FILESDIR}/${PV}-test_fix.patch"
- epatch "${FILESDIR}/${PV}-test_no_network.patch"
-
- sed -i \
- -e "/'docs/d" -e "/'test/d" \
- -e "/'fonts/d" -e "/demos/d" \
- setup.py || die "sed failed"
-
- sed -i \
- -e 's|/usr/lib/X11/fonts/TrueType/|/usr/share/fonts/ttf-bitstream-vera/|' \
- -e 's|/usr/local/Acrobat|/opt/Acrobat|g' \
- -e 's|%(HOME)s/fonts|%(HOME)s/.fonts|g' \
- -e 's|%(REPORTLAB_DIR)s/../../fonts|/usr/share/fonts|' \
- rl_config.py || die "sed failed"
-
- # A rather useless test which rebuilds the docs and fails
- # since it calls python using os.system but doesn't pass
- # the PYTHONPATH env-variable along
- rm "${S}/test/test_docs_build.py"
- # ... and remove yet another broken test
- rm "${S}/test/test_platypus_paragraphs.py"
-}
-
-src_install() {
- distutils_src_install
-
- if use doc ; then
- insinto /usr/share/doc/${PF}
- doins -r docs/*
- fi
- if use examples ; then
- insinto /usr/share/doc/${PF}
- doins -r demos
- insinto /usr/share/doc/${PF}/tools/pythonpoint
- doins -r tools/pythonpoint/demos
- fi
-}
-
-src_test() {
- cd "${S}/test"
- PYTHONPATH="../.." ${python} runAll.py || die "tests failed"
-}
diff --git a/dev-python/reportlab/reportlab-2.3.ebuild b/dev-python/reportlab/reportlab-2.3.ebuild
deleted file mode 100644
index 12231cf86543..000000000000
--- a/dev-python/reportlab/reportlab-2.3.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/reportlab/reportlab-2.3.ebuild,v 1.3 2009/09/10 02:55:37 arfrever Exp $
-
-EAPI="2"
-NEED_PYTHON="2.4"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils versionator
-
-MY_PN="ReportLab"
-MY_PV="$(replace_all_version_separators _)"
-
-DESCRIPTION="Tools for generating printable PDF documents from any data source."
-HOMEPAGE="http://www.reportlab.org/"
-SRC_URI="http://www.reportlab.org/ftp/${MY_PN}_${MY_PV}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86-fbsd ~x86"
-IUSE="doc examples test"
-
-DEPEND="sys-libs/zlib
- dev-python/imaging
- media-fonts/ttf-bitstream-vera"
-RDEPEND="${DEPEND}"
-RESTRICT_PYTHON_ABIS="3.*"
-
-S=${WORKDIR}/${MY_PN}_${MY_PV}
-
-src_prepare() {
- sed -i \
- -e 's|/usr/lib/X11/fonts/TrueType/|/usr/share/fonts/ttf-bitstream-vera/|' \
- -e 's|/usr/local/Acrobat|/opt/Acrobat|g' \
- -e 's|%(HOME)s/fonts|%(HOME)s/.fonts|g' \
- src/reportlab/rl_config.py || die "sed failed"
- epatch "${FILESDIR}/${PN}-2.2_qa_msg.patch"
-}
-
-src_compile() {
- distutils_src_compile
-
- documentation_built="0"
- build_documentation() {
- [[ "${documentation_built}" == "1" ]] && return
-
- # One of tests already builds documentation.
- if use doc && ! use test; then
- cd docs
- PYTHONPATH="$(ls -d ../build-${PYTHON_ABI}/lib*)" "$(PYTHON)" genAll.py || die "genAll.py failed"
- fi
-
- documentation_build="1"
- }
- python_execute_function -q build_documentation
- unset documentation_built
-}
-
-src_test() {
- testing() {
- "$(PYTHON)" setup.py tests-preinstall
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- # docs/reference/reportlab-reference.pdf is identical with docs/reportlab-reference.pdf
- rm -f docs/reference/reportlab-reference.pdf
-
- insinto /usr/share/doc/${PF}
- doins -r docs/*
- fi
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r demos
- insinto /usr/share/doc/${PF}/tools/pythonpoint
- doins -r tools/pythonpoint/demos
- fi
-}