summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-10-14 03:37:35 +0000
committerTim Harder <radhermit@gentoo.org>2014-10-14 03:37:35 +0000
commit90927766c8a8fec8781cdcb3680cca4461746d2b (patch)
treedcf5fb3504b1f2870bfc40efa0379ab3fe24e0b1 /dev-python/requests
parentVersion bump and update LICENSE (bug #525076). (diff)
downloadgentoo-2-90927766c8a8fec8781cdcb3680cca4461746d2b.tar.gz
gentoo-2-90927766c8a8fec8781cdcb3680cca4461746d2b.tar.bz2
gentoo-2-90927766c8a8fec8781cdcb3680cca4461746d2b.zip
Version bump.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/requests')
-rw-r--r--dev-python/requests/ChangeLog7
-rw-r--r--dev-python/requests/requests-2.4.3.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-python/requests/ChangeLog b/dev-python/requests/ChangeLog
index 838608f38701..4b3919a13143 100644
--- a/dev-python/requests/ChangeLog
+++ b/dev-python/requests/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/requests
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/requests/ChangeLog,v 1.77 2014/09/24 09:33:30 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/requests/ChangeLog,v 1.78 2014/10/14 03:37:35 radhermit Exp $
+
+*requests-2.4.3 (14 Oct 2014)
+
+ 14 Oct 2014; Tim Harder <radhermit@gentoo.org> +requests-2.4.3.ebuild:
+ Version bump.
24 Sep 2014; Agostino Sarubbo <ago@gentoo.org> requests-2.3.0.ebuild:
Stable for x86, wrt bug #513278
diff --git a/dev-python/requests/requests-2.4.3.ebuild b/dev-python/requests/requests-2.4.3.ebuild
new file mode 100644
index 000000000000..837114f32290
--- /dev/null
+++ b/dev-python/requests/requests-2.4.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/requests/requests-2.4.3.ebuild,v 1.1 2014/10/14 03:37:35 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP library for human beings"
+HOMEPAGE="http://python-requests.org/ http://pypi.python.org/pypi/requests"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+# bundles dev-python/urllib3 snapshot
+RDEPEND="app-misc/ca-certificates
+ >=dev-python/chardet-2.2.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# tests connect to various remote sites
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.2.0-system-chardet.patch \
+ "${FILESDIR}"/${PN}-2.4.0-system-cacerts.patch )
+
+python_prepare_all() {
+ # use system chardet
+ rm -r requests/packages/chardet || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" test_requests.py || die "Tests fail with ${EPYTHON}"
+}