summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-11-26 06:11:55 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-11-26 06:11:55 +0000
commit8f1e0e2d9cf78786448012aea81c14a0b088bde0 (patch)
tree053f12b01cf9346272db8cee6b8af487da09f0c0 /dev-python/setproctitle
parentBump (diff)
downloadgentoo-2-8f1e0e2d9cf78786448012aea81c14a0b088bde0.tar.gz
gentoo-2-8f1e0e2d9cf78786448012aea81c14a0b088bde0.tar.bz2
gentoo-2-8f1e0e2d9cf78786448012aea81c14a0b088bde0.zip
Bump
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/setproctitle')
-rw-r--r--dev-python/setproctitle/ChangeLog7
-rw-r--r--dev-python/setproctitle/setproctitle-1.1.8.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/dev-python/setproctitle/ChangeLog b/dev-python/setproctitle/ChangeLog
index 5a36d3946aa0..e71e005e6f64 100644
--- a/dev-python/setproctitle/ChangeLog
+++ b/dev-python/setproctitle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/setproctitle
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/setproctitle/ChangeLog,v 1.29 2013/09/05 18:46:03 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setproctitle/ChangeLog,v 1.30 2013/11/26 06:11:55 patrick Exp $
+
+*setproctitle-1.1.8 (26 Nov 2013)
+
+ 26 Nov 2013; Patrick Lauer <patrick@gentoo.org> +setproctitle-1.1.8.ebuild:
+ Bump
05 Sep 2013; Michał Górny <mgorny@gentoo.org> setproctitle-1.1.6-r1.ebuild,
setproctitle-1.1.7.ebuild:
diff --git a/dev-python/setproctitle/setproctitle-1.1.8.ebuild b/dev-python/setproctitle/setproctitle-1.1.8.ebuild
new file mode 100644
index 000000000000..bad844f80502
--- /dev/null
+++ b/dev-python/setproctitle/setproctitle-1.1.8.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setproctitle/setproctitle-1.1.8.ebuild,v 1.1 2013/11/26 06:11:55 patrick Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Allow customization of the process title."
+HOMEPAGE="http://code.google.com/p/py-setproctitle/ http://pypi.python.org/pypi/setproctitle"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+# on <py2.7 the test suite uses SkipTest from nose,
+# so we need to run it using nose.
+DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+DOCS=( HISTORY.rst README.rst )
+
+python_prepare_all() {
+ sed -i -e "/pyrun/s:%s'.*):'):" tests/*.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cp -r -l tests "${BUILD_DIR}"/ || die
+
+ if [[ ${EPYTHON} == python3.* ]]; then
+ # Notes:
+ # -W is not supported by python3.1
+ # -n causes Python to write into hardlinked files
+ 2to3 --no-diffs -w "${BUILD_DIR}"/tests/*.py || die
+ fi
+
+ cd "${BUILD_DIR}" || die
+
+ # prepare embedded executable
+ emake tests/pyrun CC="$(tc-getCC)" \
+ CPPFLAGS="${CPPFLAGS} $(python-config --cflags)" \
+ LDLIBS="${LDLIBS} $(python-config --libs)"
+
+ nosetests || die "Tests fail with ${EPYTHON}"
+}