summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-06-15 21:27:07 +0000
committerTim Harder <radhermit@gentoo.org>2014-06-15 21:27:07 +0000
commiteeec2237e92b246748efc0dbe93e3e762e73577a (patch)
tree8c36c1b1d6aafc1631398a320066a4fc9e478e0e /dev-python/setuptools
parentfix bug #513348, bump to EAPI 5, add ~amd64, thanks to Georg Rudoy (diff)
downloadgentoo-2-eeec2237e92b246748efc0dbe93e3e762e73577a.tar.gz
gentoo-2-eeec2237e92b246748efc0dbe93e3e762e73577a.tar.bz2
gentoo-2-eeec2237e92b246748efc0dbe93e3e762e73577a.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/setuptools')
-rw-r--r--dev-python/setuptools/ChangeLog7
-rw-r--r--dev-python/setuptools/setuptools-5.1.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-python/setuptools/ChangeLog b/dev-python/setuptools/ChangeLog
index bc293a00e2ba..1b28070fd4a6 100644
--- a/dev-python/setuptools/ChangeLog
+++ b/dev-python/setuptools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/setuptools
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/ChangeLog,v 1.230 2014/06/15 04:17:12 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/ChangeLog,v 1.231 2014/06/15 21:27:07 radhermit Exp $
+
+*setuptools-5.1 (15 Jun 2014)
+
+ 15 Jun 2014; Tim Harder <radhermit@gentoo.org> +setuptools-5.1.ebuild:
+ Version bump.
*setuptools-5.0.1 (15 Jun 2014)
diff --git a/dev-python/setuptools/setuptools-5.1.ebuild b/dev-python/setuptools/setuptools-5.1.ebuild
new file mode 100644
index 000000000000..74643eb388e4
--- /dev/null
+++ b/dev-python/setuptools/setuptools-5.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/setuptools/setuptools-5.1.ebuild,v 1.1 2014/06/15 21:27:07 radhermit Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="a collection of extensions to Distutils"
+HOMEPAGE="http://pypi.python.org/pypi/setuptools"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# Force in-source build because build system modifies sources.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DOCS=( README.txt docs/{easy_install.txt,pkg_resources.txt,setuptools.txt} )
+
+python_prepare_all() {
+ # Disable tests requiring network connection.
+ rm -f setuptools/tests/test_packageindex.py
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
+ # It tries to sandbox the test in a tempdir
+ HOME="${PWD}" esetup.py test
+}
+
+python_install() {
+ export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
+ distutils-r1_python_install
+}