summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-12 02:03:49 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-12 02:03:49 +0000
commit54039feb6daa56d7723e58c52bc2127d44887536 (patch)
treedbcf086940944f46a72c1d63dec4cad548ead8fe /dev-python/sphinx
parentStable for HPPA (bug #280617). (diff)
downloadgentoo-2-54039feb6daa56d7723e58c52bc2127d44887536.tar.gz
gentoo-2-54039feb6daa56d7723e58c52bc2127d44887536.tar.bz2
gentoo-2-54039feb6daa56d7723e58c52bc2127d44887536.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: 14007-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/sphinx')
-rw-r--r--dev-python/sphinx/ChangeLog6
-rw-r--r--dev-python/sphinx/sphinx-0.6.2.ebuild35
2 files changed, 29 insertions, 12 deletions
diff --git a/dev-python/sphinx/ChangeLog b/dev-python/sphinx/ChangeLog
index 09600e97c95e..a518fb640726 100644
--- a/dev-python/sphinx/ChangeLog
+++ b/dev-python/sphinx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/sphinx
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/ChangeLog,v 1.23 2009/08/09 16:38:17 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/ChangeLog,v 1.24 2009/08/12 02:03:49 arfrever Exp $
+
+ 12 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ sphinx-0.6.2.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
09 Aug 2009; Raúl Porcel <armin76@gentoo.org> sphinx-0.6.1-r1.ebuild:
alpha/arm/ia64/s390/sh/sparc stable wrt #278978
diff --git a/dev-python/sphinx/sphinx-0.6.2.ebuild b/dev-python/sphinx/sphinx-0.6.2.ebuild
index f1cbe1ad2548..521440fa305e 100644
--- a/dev-python/sphinx/sphinx-0.6.2.ebuild
+++ b/dev-python/sphinx/sphinx-0.6.2.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-0.6.2.ebuild,v 1.3 2009/07/15 03:12:08 neurogeek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sphinx/sphinx-0.6.2.ebuild,v 1.4 2009/08/12 02:03:49 arfrever Exp $
EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
inherit distutils
MY_PN="Sphinx"
@@ -24,13 +26,15 @@ DEPEND="${RDEPEND}
dev-python/setuptools
test? ( dev-python/nose )"
+RESTRICT_PYTHON_ABIS="3*"
+
S="${WORKDIR}/${MY_P}"
src_compile() {
DOCS="CHANGES"
distutils_src_compile
- if use doc ; then
+ if use doc; then
cd doc
PYTHONPATH="../" emake \
SPHINXBUILD="${python} ../sphinx-build.py" \
@@ -38,28 +42,37 @@ src_compile() {
fi
}
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" nosetests
+ }
+ python_execute_function testing
+}
+
src_install() {
distutils_src_install
- if use doc ; then
+ if use doc; then
dohtml -A txt -r doc/_build/html/* || die
fi
}
-src_test() {
- PYTHONPATH="./build/lib" nosetests || die "Tests failed"
-}
-
pkg_postinst() {
distutils_pkg_postinst
# Generating the Grammar pickle to avoid on the fly generation causing sandbox violations (bug #266015)
- "${python}" \
- -c "from sphinx.pycode.pgen2.driver import load_grammar ; load_grammar('${ROOT}/usr/$(get_libdir)/python${PYVER}/site-packages/sphinx/pycode/Grammar.txt')" \
- || die "generating grammar pickle failed"
+ generation_of_grammar_pickle() {
+ "$(PYTHON)" -c "from sphinx.pycode.pgen2.driver import load_grammar; load_grammar('${ROOT}$(python_get_sitedir)/sphinx/pycode/Grammar.txt')" \
+ || die "Generation of grammar pickle failed"
+ }
+ python_execute_function --action-message 'Generation of Grammar pickle with Python ${PYTHON_ABI}...' generation_of_grammar_pickle
}
pkg_postrm() {
- rm "${ROOT}/usr/$(get_libdir)/python${PYVER}/site-packages/sphinx/pycode"/Grammar*.pickle
distutils_pkg_postrm
+
+ deletion_of_grammar_pickle() {
+ rm "${ROOT}$(python_get_sitedir)/sphinx/pycode"/Grammar*.pickle
+ }
+ python_execute_function --action-message 'Deletion of Grammar pickle with Python ${PYTHON_ABI}...' deletion_of_grammar_pickle
}