summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-04-19 13:56:41 +0000
committerIan Delaney <idella4@gentoo.org>2013-04-19 13:56:41 +0000
commit217ce0f372131fdc8c73216838f424f56b421c5a (patch)
treed1c63d142e8f82cebd6388264898c268373f3b90 /dev-python/starcluster
parentbump to EAPI5 (diff)
downloadgentoo-2-217ce0f372131fdc8c73216838f424f56b421c5a.tar.gz
gentoo-2-217ce0f372131fdc8c73216838f424f56b421c5a.tar.bz2
gentoo-2-217ce0f372131fdc8c73216838f424f56b421c5a.zip
migration -> distutils-r1
(Portage version: 2.1.11.60/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/starcluster')
-rw-r--r--dev-python/starcluster/ChangeLog7
-rw-r--r--dev-python/starcluster/starcluster-0.93.3-r1.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/dev-python/starcluster/ChangeLog b/dev-python/starcluster/ChangeLog
index 074f0b30f409..9e2dd05df5ed 100644
--- a/dev-python/starcluster/ChangeLog
+++ b/dev-python/starcluster/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/starcluster
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/starcluster/ChangeLog,v 1.7 2013/03/04 16:22:19 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/starcluster/ChangeLog,v 1.8 2013/04/19 13:56:41 idella4 Exp $
+
+*starcluster-0.93.3-r1 (19 Apr 2013)
+
+ 19 Apr 2013; Ian Delaney <idella4@gentoo.org> +starcluster-0.93.3-r1.ebuild:
+ migration -> distutils-r1
04 Mar 2013; Ian Delaney <idella4@gentoo.org> starcluster-0.93.3.ebuild:
Update dep jinja, prompt from quantumsummers & jtriley
diff --git a/dev-python/starcluster/starcluster-0.93.3-r1.ebuild b/dev-python/starcluster/starcluster-0.93.3-r1.ebuild
new file mode 100644
index 000000000000..d4cc3636de88
--- /dev/null
+++ b/dev-python/starcluster/starcluster-0.93.3-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/starcluster/starcluster-0.93.3-r1.ebuild,v 1.1 2013/04/19 13:56:41 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils-r1 bash-completion-r1
+MY_PN=StarCluster
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Utility for creating / managing general purpose computing clusters"
+HOMEPAGE="http://web.mit.edu/star/cluster"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="doc bash-completion epydoc"
+
+RDEPEND=">=dev-python/ssh-1.7.13[${PYTHON_USEDEP}]
+ >=dev-python/boto-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.6-r1[${PYTHON_USEDEP}]
+ >=dev-python/decorator-3.1.1[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.0.13_beta[${PYTHON_USEDEP}]
+ >=dev-python/workerpool-0.9.2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/epydoc[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}"/${P}-requires.patch )
+
+python_compile_all() {
+ use doc && emake -C docs/sphinx html
+ mkdocs() {
+ local exit_status=0
+ local msg="build with epydoc failed"
+ pushd docs/epydoc/
+ PATH=$PATH:./ PYTHONPATH="${BUILD_DIR}/lib" ./build.sh || exit_status=1
+ [[ $exit_status != 0 ]] && eerror "$msg"
+ popd sets
+ return $exit_status
+ }
+ use epydoc && mkdocs
+}
+python_install() {
+ dobashcomp "${S}"/completion/${PN}-completion.sh ${PN}
+
+ use doc && dohtml -r docs/sphinx/_build/html/
+ if use epydoc; then
+ docompress -x usr/share/doc/${PF}/apidocs/api-objects.txt
+ insinto usr/share/doc/${PF}/
+ doins -r "${S}"/docs/apidocs/
+ fi
+}
+
+python_test() {
+ nosetests || die -v ${PN}/tests || die
+}