summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-02-22 03:34:54 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-02-22 03:34:54 +0000
commit61ea6a48be72c2f4c39e991f8737f4efc9a951e8 (patch)
treea67412f9ec0bd7b5f22f7158e7cb22bffa41689a /dev-python/subunit
parentDuplicating makemkv 1.7.8 patch for 1.8.0, will see how it behaves during tes... (diff)
downloadgentoo-2-61ea6a48be72c2f4c39e991f8737f4efc9a951e8.tar.gz
gentoo-2-61ea6a48be72c2f4c39e991f8737f4efc9a951e8.tar.bz2
gentoo-2-61ea6a48be72c2f4c39e991f8737f4efc9a951e8.zip
Bump
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, RepoMan options: --force, unsigned Manifest commit)
Diffstat (limited to 'dev-python/subunit')
-rw-r--r--dev-python/subunit/ChangeLog7
-rw-r--r--dev-python/subunit/subunit-0.0.10.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-python/subunit/ChangeLog b/dev-python/subunit/ChangeLog
index 97304a86123f..0a2eaad0bca9 100644
--- a/dev-python/subunit/ChangeLog
+++ b/dev-python/subunit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/subunit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/ChangeLog,v 1.21 2013/01/13 12:54:58 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/ChangeLog,v 1.22 2013/02/22 03:34:54 patrick Exp $
+
+*subunit-0.0.10 (22 Feb 2013)
+
+ 22 Feb 2013; Patrick Lauer <patrick@gentoo.org> +subunit-0.0.10.ebuild:
+ Bump
13 Jan 2013; Christian Faulhammer <fauli@gentoo.org> -subunit-0.0.7.ebuild:
clean up
diff --git a/dev-python/subunit/subunit-0.0.10.ebuild b/dev-python/subunit/subunit-0.0.10.ebuild
new file mode 100644
index 000000000000..44aefcb498f5
--- /dev/null
+++ b/dev-python/subunit/subunit-0.0.10.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/subunit/subunit-0.0.10.ebuild,v 1.1 2013/02/22 03:34:54 patrick Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_EXPORT_PHASE_FUNCTIONS="1"
+
+# Automake build does not genereate the correct value for site-packages
+# with pypy.
+RESTRICT_PYTHON_ABIS="*-pypy-*"
+
+inherit python
+
+DESCRIPTION="A streaming protocol for test results"
+HOMEPAGE="https://launchpad.net/subunit http://pypi.python.org/pypi/python-subunit"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-python/testtools-0.9.23"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-libs/check
+ dev-util/cppunit
+ virtual/pkgconfig"
+
+src_prepare() {
+ python_clean_py-compile_files
+ python_src_prepare
+}
+
+src_test() {
+ testing() {
+ python_convert_shebangs ${PYTHON_ABI} runtests.py || return
+ emake check
+ }
+ python_execute_function -s testing
+}
+
+pkg_postinst() {
+ python_mod_optimize subunit
+}
+
+pkg_postrm() {
+ python_mod_cleanup subunit
+}