summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-10-16 16:28:25 +0000
committerJustin Lecher <jlec@gentoo.org>2013-10-16 16:28:25 +0000
commita8d04e460c866d7a34d77106f516b3f71c0c6c7e (patch)
tree52582b2ee1d53a7164d7fda9146af45b724e1bb0 /dev-python/sympy
parentMarked ~hppa (bug #488236). (diff)
downloadgentoo-2-a8d04e460c866d7a34d77106f516b3f71c0c6c7e.tar.gz
gentoo-2-a8d04e460c866d7a34d77106f516b3f71c0c6c7e.tar.bz2
gentoo-2-a8d04e460c866d7a34d77106f516b3f71c0c6c7e.zip
dev-python/sympy: Fix problems with doc building, #488172; simplify py 2/3 selection code
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-python/sympy')
-rw-r--r--dev-python/sympy/ChangeLog5
-rw-r--r--dev-python/sympy/sympy-0.7.3.ebuild56
2 files changed, 39 insertions, 22 deletions
diff --git a/dev-python/sympy/ChangeLog b/dev-python/sympy/ChangeLog
index 5567e723620a..fcd4fcbb8ea8 100644
--- a/dev-python/sympy/ChangeLog
+++ b/dev-python/sympy/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/sympy
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sympy/ChangeLog,v 1.25 2013/10/15 18:17:35 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sympy/ChangeLog,v 1.26 2013/10/16 16:28:25 jlec Exp $
+
+ 16 Oct 2013; Justin Lecher <jlec@gentoo.org> sympy-0.7.3.ebuild:
+ Fix problems with doc building, #488172; simplify py 2/3 selection code
*sympy-0.7.3 (15 Oct 2013)
diff --git a/dev-python/sympy/sympy-0.7.3.ebuild b/dev-python/sympy/sympy-0.7.3.ebuild
index ab3275b904e9..a270b45dcbb7 100644
--- a/dev-python/sympy/sympy-0.7.3.ebuild
+++ b/dev-python/sympy/sympy-0.7.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sympy/sympy-0.7.3.ebuild,v 1.1 2013/10/15 18:17:35 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sympy/sympy-0.7.3.ebuild,v 1.2 2013/10/16 16:28:25 jlec Exp $
EAPI=5
@@ -157,58 +157,72 @@ src_prepare() {
}
python_compile() {
+ local _py
if python_is_python3; then
- cd "${WORKDIR}"/python3/${P} || die
- export S="${WORKDIR}"/python3/${P}
+ _py=3
else
- cd "${WORKDIR}"/python2/${P} || die
- export S="${WORKDIR}"/python2/${P}
+ _py=2
fi
+
+ cd "${WORKDIR}"/python${_py}/${P} || die
+ export S="${WORKDIR}"/python${_py}/${P}
+
PYTHONPATH="." distutils-r1_python_compile
}
python_compile_all() {
+ local _py
if use doc; then
if python_is_python3; then
- cd "${WORKDIR}"/python3/${P} || die
- emake html
+ _py=3
else
- cd "${WORKDIR}"/python2/${P} || die
- emake html
+ _py=2
fi
+
+ cd "${WORKDIR}"/python${_py}/${P}/doc || die
+ emake html
+
fi
}
-DISTUTILS_NO_PARALLEL_BUILD=true
+
python_test() {
+ local _py
if python_is_python3; then
- cd "${WORKDIR}"/python3/${P} || die
+ _py=3
else
- cd "${WORKDIR}"/python2/${P} || die
+ _py=2
fi
+
+ cd "${WORKDIR}"/python${_py}/${P} || die
PYTHONPATH="." py.test || ewarn "tests with ${EPYTHON} failed"
}
python_install() {
+ local _py
if python_is_python3; then
- cd "${WORKDIR}"/python3/${P} || die
- export S="${WORKDIR}"/python3/${P}
+ _py=3
else
- cd "${WORKDIR}"/python2/${P} || die
- export S="${WORKDIR}"/python2/${P}
+ _py=2
fi
+
+ cd "${WORKDIR}"/python${_py}/${P} || die
+ export S="${WORKDIR}"/python${_py}/${P}
+
PYTHONPATH="." distutils-r1_python_install
}
python_install_all() {
+ local _py
distutils-r1_python_install_all
if python_is_python3; then
- cd "${WORKDIR}"/python3/${P} || die
+ _py=3
else
- cd "${WORKDIR}"/python2/${P} || die
- fi
- if use doc; then
- dohtml -r doc/_build/html/*
+ _py=2
fi
+
+ cd "${WORKDIR}"/python${_py}/${P} || die
+ use doc && dohtml -r doc/_build/html/*
+
if use examples; then
insinto /usr/share/doc/${P}
doins -r examples