summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-10-15 11:36:28 +0000
committerIan Delaney <idella4@gentoo.org>2014-10-15 11:36:28 +0000
commit240e2e81f14a780e40b4b306a0a49823e38d231a (patch)
tree446e5b49c02db14ba2826c61a10ee9162d5216de /dev-python/testify
parentSupport multilib providers for deps. Bump to EAPI=5. (diff)
downloadgentoo-2-240e2e81f14a780e40b4b306a0a49823e38d231a.tar.gz
gentoo-2-240e2e81f14a780e40b4b306a0a49823e38d231a.tar.bz2
gentoo-2-240e2e81f14a780e40b4b306a0a49823e38d231a.zip
bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/testify')
-rw-r--r--dev-python/testify/ChangeLog7
-rw-r--r--dev-python/testify/testify-0.3.7.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-python/testify/ChangeLog b/dev-python/testify/ChangeLog
index a3216746e066..9bfe208ba8a9 100644
--- a/dev-python/testify/ChangeLog
+++ b/dev-python/testify/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/testify
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/ChangeLog,v 1.16 2014/08/28 16:46:43 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/ChangeLog,v 1.17 2014/10/15 11:36:28 idella4 Exp $
+
+*testify-0.3.7 (15 Oct 2014)
+
+ 15 Oct 2014; Ian Delaney <idella4@gentoo.org> +testify-0.3.7.ebuild:
+ bump
*testify-0.3.6 (28 Aug 2014)
diff --git a/dev-python/testify/testify-0.3.7.ebuild b/dev-python/testify/testify-0.3.7.ebuild
new file mode 100644
index 000000000000..81bb1790cbac
--- /dev/null
+++ b/dev-python/testify/testify-0.3.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/testify-0.3.7.ebuild,v 1.1 2014/10/15 11:36:28 idella4 Exp $
+
+EAPI=5
+
+# Still appears to no support >=py3.3
+PYTHON_COMPAT=( python2_7 pypy )
+RESTRICT="test" # basically still very broken
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="A more pythonic replacement for the unittest module and nose"
+HOMEPAGE="https://github.com/Yelp/testify http://pypi.python.org/pypi/testify/"
+SRC_URI="https://github.com/Yelp/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+# There is another undocumented dep req'd for the testsuite; catbox
+DOCS="README.md"
+
+python_prepare_all() {
+ # Correct typo in setup.py
+ sed -e 's:mock,:mock:' -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # https://github.com/Yelp/Testify/issues/283
+ "${PYTHON}" bin/${PN} test || die
+}