summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-03 12:31:12 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-03 12:31:12 +0000
commiteeb16e925a0bc4de5ed5b229c5c750cc26ad394e (patch)
tree1ea5e5d70448ca132f7deae19f113dda5d0afade /dev-python/traitsgui
parentLet USE=-extras still build important utils like ata_id and usb_id. Backporte... (diff)
downloadgentoo-2-eeb16e925a0bc4de5ed5b229c5c750cc26ad394e.tar.gz
gentoo-2-eeb16e925a0bc4de5ed5b229c5c750cc26ad394e.tar.bz2
gentoo-2-eeb16e925a0bc4de5ed5b229c5c750cc26ad394e.zip
Don't install some files to avoid file collisions with dev-python/namespaces-enthought.
(Portage version: 2.2.0_alpha29_p5/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/traitsgui')
-rw-r--r--dev-python/traitsgui/ChangeLog10
-rw-r--r--dev-python/traitsgui/files/traitsgui-3.6.0-namespaces.patch11
-rw-r--r--dev-python/traitsgui/traitsgui-3.6.0-r1.ebuild (renamed from dev-python/traitsgui/traitsgui-3.6.0.ebuild)11
3 files changed, 28 insertions, 4 deletions
diff --git a/dev-python/traitsgui/ChangeLog b/dev-python/traitsgui/ChangeLog
index b64179baa789..5ffbfb296ef5 100644
--- a/dev-python/traitsgui/ChangeLog
+++ b/dev-python/traitsgui/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/traitsgui
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/traitsgui/ChangeLog,v 1.18 2011/04/01 16:32:16 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/traitsgui/ChangeLog,v 1.19 2011/04/03 12:31:12 arfrever Exp $
+
+*traitsgui-3.6.0-r1 (03 Apr 2011)
+
+ 03 Apr 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -traitsgui-3.6.0.ebuild, +traitsgui-3.6.0-r1.ebuild,
+ +files/traitsgui-3.6.0-namespaces.patch:
+ Don't install some files to avoid file collisions with
+ dev-python/namespaces-enthought.
01 Apr 2011; Kacper Kowalik <xarthisius@gentoo.org> traitsgui-3.6.0.ebuild:
Marked ~ppc64 wrt #342297
diff --git a/dev-python/traitsgui/files/traitsgui-3.6.0-namespaces.patch b/dev-python/traitsgui/files/traitsgui-3.6.0-namespaces.patch
new file mode 100644
index 000000000000..6a8b5e6cbc30
--- /dev/null
+++ b/dev-python/traitsgui/files/traitsgui-3.6.0-namespaces.patch
@@ -0,0 +1,11 @@
+--- setup.py
++++ setup.py
+@@ -70,6 +70,8 @@
+ "enthought",
+ "enthought.pyface",
+ "enthought.pyface.ui",
++ "enthought.traits",
++ "enthought.traits.ui",
+ ],
+ package_data = {
+ '': ['library/*', 'images/*'],
diff --git a/dev-python/traitsgui/traitsgui-3.6.0.ebuild b/dev-python/traitsgui/traitsgui-3.6.0-r1.ebuild
index 23efa0b89463..8258f00db661 100644
--- a/dev-python/traitsgui/traitsgui-3.6.0.ebuild
+++ b/dev-python/traitsgui/traitsgui-3.6.0-r1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/traitsgui/traitsgui-3.6.0.ebuild,v 1.7 2011/04/01 16:32:16 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/traitsgui/traitsgui-3.6.0-r1.ebuild,v 1.1 2011/04/03 12:31:12 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.* *-jython"
-inherit distutils
+inherit distutils eutils
MY_PN="TraitsGUI"
MY_P="${MY_PN}-${PV}"
@@ -34,13 +34,18 @@ S="${WORKDIR}/${MY_P}"
DOCS="docs/*.txt"
PYTHON_MODNAME="enthought"
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}/${P}-namespaces.patch"
+}
+
src_compile() {
distutils_src_compile
if use doc; then
einfo "Generation of documentation"
pushd docs > /dev/null
- emake html || die "Generation of documentation failed"
+ PYTHONPATH=".." emake html || die "Generation of documentation failed"
popd > /dev/null
fi
}