summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2007-05-07 14:41:58 +0000
committerRob Cakebread <pythonhead@gentoo.org>2007-05-07 14:41:58 +0000
commit003d3a8ef526e2929cbcf5194707625a02f70153 (patch)
tree51777653314ecf454c46d6f950432a39dc9d4806 /dev-python/turbogears/files
parentStable on sparc (diff)
downloadgentoo-2-003d3a8ef526e2929cbcf5194707625a02f70153.tar.gz
gentoo-2-003d3a8ef526e2929cbcf5194707625a02f70153.tar.bz2
gentoo-2-003d3a8ef526e2929cbcf5194707625a02f70153.zip
Fixes setuptools bug #177433. Thanks Santiago Gala <sgala@apache.org>
(Portage version: 2.1.2.5)
Diffstat (limited to 'dev-python/turbogears/files')
-rw-r--r--dev-python/turbogears/files/turbogears-1.0.2.2-gentoo-setuptools.diff61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/turbogears/files/turbogears-1.0.2.2-gentoo-setuptools.diff b/dev-python/turbogears/files/turbogears-1.0.2.2-gentoo-setuptools.diff
new file mode 100644
index 000000000000..6b43b4e336ea
--- /dev/null
+++ b/dev-python/turbogears/files/turbogears-1.0.2.2-gentoo-setuptools.diff
@@ -0,0 +1,61 @@
+--- setup.py.orig 2007-05-07 07:28:49.000000000 -0700
++++ setup.py 2007-05-07 07:30:16.000000000 -0700
+@@ -10,36 +10,9 @@
+ execfile(os.path.join("turbogears", "release.py"))
+
+ # setup params
+-install_requires = [
+- "TurboJson >= 0.9.9",
+- "TurboCheetah >= 0.9.5",
+- "TurboKid >= 1.0.1",
+- "CherryPy >= 2.2.1,<3.0.0alpha",
+- "simplejson >= 1.3",
+- "elementtree >= 1.2.6",
+- "PasteScript >= 0.9.7",
+- "FormEncode >= 0.7.1",
+- "setuptools >= 0.6c2",
+- "RuleDispatch >= 0.5a0.dev-r2303",
+- "DecoratorTools >= 1.4",
+- "ConfigObj >= 4.3.2"]
+ tgtesttools = ["nose >= 0.9.1", "SQLAlchemy>=0.3"]
+ standard = ["SQLObject>=0.8,<0.10dev"]
+
+-# python 2.5 compatible list
+-if sys.version_info < (2, 5):
+- install_requires.extend([
+- "cElementTree >= 1.0.5",
+- ])
+- tgtesttools.extend([
+- "pysqlite"
+- ])
+- standard = ["SQLObject==bugfix,>=0.7.1dev-r1860,<=0.7.99"]
+-else:
+- install_requires.extend([
+- "Cheetah >= 2.0rc7",
+- ])
+-
+
+ setup(
+ name="TurboGears",
+@@ -70,7 +43,6 @@
+ the TurboGears subversion repository</a>.""",
+ url="http://www.turbogears.org",
+ zip_safe=False,
+- install_requires = install_requires,
+ packages=find_packages(),
+ include_package_data=True,
+ exclude_package_data={"thirdparty": ["*"]},
+@@ -117,13 +89,6 @@
+ catwalk = turbogears.toolbox.catwalk:CatWalk
+
+ """,
+- extras_require = {
+- "exp" : ["TGFastData"],
+- "standard" : standard,
+- "future" : ["Genshi>=0.3", "SQLAlchemy>=0.3"],
+- "testtools" : ["nose >= 0.9.1"],
+- "tgtesttools" : tgtesttools,
+- },
+ classifiers = [
+ 'Development Status :: 5 - Production/Stable',
+ 'Environment :: Console',