summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-03-10 09:04:27 +0000
committerIan Delaney <idella4@gentoo.org>2013-03-10 09:04:27 +0000
commit9b501c07ab5a89ceb430def8ecc6965ba710fb43 (patch)
tree63e49dfa08441d2906c690aff9f79ba56a90ed74 /dev-python/tweepy
parentQA: add missing inherit on eutils eclass - needed for domenu (diff)
downloadgentoo-2-9b501c07ab5a89ceb430def8ecc6965ba710fb43.tar.gz
gentoo-2-9b501c07ab5a89ceb430def8ecc6965ba710fb43.tar.bz2
gentoo-2-9b501c07ab5a89ceb430def8ecc6965ba710fb43.zip
bump
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/tweepy')
-rw-r--r--dev-python/tweepy/ChangeLog7
-rw-r--r--dev-python/tweepy/tweepy-2.0.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-python/tweepy/ChangeLog b/dev-python/tweepy/ChangeLog
index 793b370de4e1..d98365d78d78 100644
--- a/dev-python/tweepy/ChangeLog
+++ b/dev-python/tweepy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/tweepy
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/tweepy/ChangeLog,v 1.2 2013/01/22 08:17:37 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/tweepy/ChangeLog,v 1.3 2013/03/10 09:04:27 idella4 Exp $
+
+*tweepy-2.0 (10 Mar 2013)
+
+ 10 Mar 2013; Ian Delaney <idella4@gentoo.org> +tweepy-2.0.ebuild:
+ bump
*tweepy-1.13 (22 Jan 2013)
diff --git a/dev-python/tweepy/tweepy-2.0.ebuild b/dev-python/tweepy/tweepy-2.0.ebuild
new file mode 100644
index 000000000000..46e86ac43b56
--- /dev/null
+++ b/dev-python/tweepy/tweepy-2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/tweepy/tweepy-2.0.ebuild,v 1.1 2013/03/10 09:04:27 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy{1_9,2_0} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="A Python library for accessing the Twitter API "
+HOMEPAGE="http://tweepy.github.com/"
+SRC_URI="https://github.com/tweepy/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+DOCS="README.md"
+RESTRICT="test" #fails all
+
+python_test() {
+ "${PYTHON}" -m tests || die "Tests failed"
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ dodoc ${DOCS}
+ use doc && dohtml -r docs/_build/html/
+
+ if use examples; then
+ docinto examples
+ dodoc examples/*
+ fi
+}