summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-30 22:18:29 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-30 22:18:29 +0000
commit631a5d939b402641a2d0c1b9ffee01a3b223ab9c (patch)
tree4e809a42509c63265f5ce68ddb2351c11de64393 /dev-python/twill/twill-0.9.ebuild
parentFix dependencies. Set SUPPORT_PYTHON_ABIS. Add "examples" USE flag. (diff)
downloadgentoo-2-631a5d939b402641a2d0c1b9ffee01a3b223ab9c.tar.gz
gentoo-2-631a5d939b402641a2d0c1b9ffee01a3b223ab9c.tar.bz2
gentoo-2-631a5d939b402641a2d0c1b9ffee01a3b223ab9c.zip
Fix dependencies. Set SUPPORT_PYTHON_ABIS.
(Portage version: 2.2.0_alpha10_p22/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/twill/twill-0.9.ebuild')
-rw-r--r--dev-python/twill/twill-0.9.ebuild29
1 files changed, 18 insertions, 11 deletions
diff --git a/dev-python/twill/twill-0.9.ebuild b/dev-python/twill/twill-0.9.ebuild
index e19bdcc125da..bd931b8b7967 100644
--- a/dev-python/twill/twill-0.9.ebuild
+++ b/dev-python/twill/twill-0.9.ebuild
@@ -1,6 +1,11 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twill/twill-0.9.ebuild,v 1.1 2009/02/15 14:24:58 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twill/twill-0.9.ebuild,v 1.2 2010/12/30 22:18:29 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit distutils
@@ -10,25 +15,27 @@ MY_P="${PN}-${MY_PV}"
DESCRIPTION="Simple scripting language for web browsing with Python API."
HOMEPAGE="http://twill.idyll.org/"
SRC_URI="http://darcs.idyll.org/~t/projects/${MY_P}.tar.gz"
+
LICENSE="MIT"
-KEYWORDS="~amd64 ~x86"
SLOT="0"
+KEYWORDS="~amd64 ~x86"
IUSE="doc"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
+
+src_test() {
+ elog "Testing disabled due to sandbox problems opening"
+ elog "a port on a server. Unpack the ebuild and run the"
+ elog "tests manually with 'nosetests' (dev-python/nose)"
+ elog "in the unpacked directory."
+}
src_install() {
distutils_src_install
+
if use doc; then
dodir /usr/share/doc/${PF}/examples
cp -R doc/* "${D}"/usr/share/doc/${PF}/
cp examples/* "${D}"/usr/share/doc/${PF}/examples/
fi
}
-
-src_test() {
- elog "Testing disabled due to sandbox prolems opening"
- elog "a port on a server. Unpack the ebuild and run the"
- elog "tests manually with 'nosetests' (dev-python/nose)"
- elog "in the unpacked directory."
-}