summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2003-12-13 04:36:16 +0000
committerBryan Østergaard <kloeri@gentoo.org>2003-12-13 04:36:16 +0000
commit93497abb8041e361ca3f88b24af376db51f83336 (patch)
treef4e0b1e4b62d6545e961d68d53f6fa66b99d19f2 /dev-python/twisted
parentmove vcron to vixie-cron (diff)
downloadgentoo-2-93497abb8041e361ca3f88b24af376db51f83336.tar.gz
gentoo-2-93497abb8041e361ca3f88b24af376db51f83336.tar.bz2
gentoo-2-93497abb8041e361ca3f88b24af376db51f83336.zip
Version bump.
Diffstat (limited to 'dev-python/twisted')
-rw-r--r--dev-python/twisted/ChangeLog7
-rw-r--r--dev-python/twisted/Manifest6
-rw-r--r--dev-python/twisted/files/digest-twisted-1.1.11
-rw-r--r--dev-python/twisted/twisted-1.1.1.ebuild35
4 files changed, 46 insertions, 3 deletions
diff --git a/dev-python/twisted/ChangeLog b/dev-python/twisted/ChangeLog
index e16bc95356af..a37cae973779 100644
--- a/dev-python/twisted/ChangeLog
+++ b/dev-python/twisted/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/twisted
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.27 2003/12/06 14:55:57 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.28 2003/12/13 04:33:21 kloeri Exp $
+
+*twisted-1.1.1 (13 Dec 2003)
+
+ 13 Dec 2003; Bryan Østergaard,,, <kloeri@gentoo.org> twisted-1.1.1.ebuild:
+ Version bump.
06 Dec 2003; Alastair Tse <liquidx@gentoo.org> twisted-1.0.6.ebuild,
twisted-1.0.7.ebuild, twisted-1.0.7_rc1.ebuild, twisted-1.1.0.ebuild:
diff --git a/dev-python/twisted/Manifest b/dev-python/twisted/Manifest
index d1cb5d9a00c1..ab035a0435d1 100644
--- a/dev-python/twisted/Manifest
+++ b/dev-python/twisted/Manifest
@@ -1,4 +1,6 @@
-MD5 785ac548c10896d6b4a5a2de12150b7e ChangeLog 7021
-MD5 19df39ef54fc4a8677998f19bb6046ac metadata.xml 218
MD5 88396863d0c8ee459ff4dae7a54b94fb twisted-1.1.0.ebuild 1007
+MD5 355730e4b18ba81921898af7cc2cac13 twisted-1.1.1.ebuild 1038
+MD5 d82c902c17c65e36daeb97670cbfcc9f ChangeLog 7144
+MD5 19df39ef54fc4a8677998f19bb6046ac metadata.xml 218
MD5 5c2c68c5857f1ad5b44c0672c5fd0671 files/digest-twisted-1.1.0 74
+MD5 42bffa410158df2c1ce98e01c24a599c files/digest-twisted-1.1.1 74
diff --git a/dev-python/twisted/files/digest-twisted-1.1.1 b/dev-python/twisted/files/digest-twisted-1.1.1
new file mode 100644
index 000000000000..0c391a32065a
--- /dev/null
+++ b/dev-python/twisted/files/digest-twisted-1.1.1
@@ -0,0 +1 @@
+MD5 f12cd12b5b2b90f85e6cfb5005fdfc91 Twisted_NoDocs-1.1.1.tar.bz2 1200027
diff --git a/dev-python/twisted/twisted-1.1.1.ebuild b/dev-python/twisted/twisted-1.1.1.ebuild
new file mode 100644
index 000000000000..ead5064034ee
--- /dev/null
+++ b/dev-python/twisted/twisted-1.1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-1.1.1.ebuild,v 1.1 2003/12/13 04:33:21 kloeri Exp $
+
+inherit distutils
+
+DESCRIPTION="collection of servers and clients, which can be used either by developers of new applications or directly. Documentation included."
+HOMEPAGE="http://www.twistedmatrix.com/"
+SRC_URI="http://twisted.sourceforge.net/Twisted_NoDocs-${PV}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="gtk2 doc"
+
+DEPEND=">=dev-lang/python-2.2
+ >=dev-python/pycrypto-1.9_alpha6
+ dev-python/pyserial
+ dev-python/pyOpenSSL
+ !gtk2? ( =dev-python/pygtk-0.6* )
+ gtk2? ( >=dev-python/pygtk-1.99* )
+ doc? ( =dev-python/twisted-docs-${PV} )"
+
+S=${WORKDIR}/Twisted-${PV}
+
+src_install() {
+ distutils_src_install
+
+ # use gtk2 if they so wish
+ if [ -n "`use gtk2`" ]; then
+ sed -e 's/import manhole/import manhole2/' \
+ -e 's/manhole\.run()/manhole2.run()/' \
+ -i ${D}/usr/bin/manhole
+ fi
+}