summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-04-06 15:19:42 +0000
committerAlex Brandt <alunduil@gentoo.org>2015-04-06 15:19:42 +0000
commit5de81f1670bfde2fff308e9364dda99c9ea4b069 (patch)
tree23ac3da97270f8de3879647c7b1695e468490c93 /dev-python/unittest2
parentVersion Bump (diff)
downloadgentoo-2-5de81f1670bfde2fff308e9364dda99c9ea4b069.tar.gz
gentoo-2-5de81f1670bfde2fff308e9364dda99c9ea4b069.tar.bz2
gentoo-2-5de81f1670bfde2fff308e9364dda99c9ea4b069.zip
add fixes proposed by Arfrever
* RDEPEND and DEPEND on dev-python/setuptools * drop dependence on dev-python/linecache2 * drop sed (suspect return value) and use patch (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 11A8217C!)
Diffstat (limited to 'dev-python/unittest2')
-rw-r--r--dev-python/unittest2/ChangeLog10
-rw-r--r--dev-python/unittest2/files/remove-argparse-dependence.patch12
-rw-r--r--dev-python/unittest2/unittest2-1.0.1-r1.ebuild37
3 files changed, 58 insertions, 1 deletions
diff --git a/dev-python/unittest2/ChangeLog b/dev-python/unittest2/ChangeLog
index 84e93a9ce9e4..4fc09d36ed11 100644
--- a/dev-python/unittest2/ChangeLog
+++ b/dev-python/unittest2/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/unittest2
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/unittest2/ChangeLog,v 1.58 2015/04/03 20:54:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/unittest2/ChangeLog,v 1.59 2015/04/06 15:19:42 alunduil Exp $
+
+*unittest2-1.0.1-r1 (06 Apr 2015)
+
+ 06 Apr 2015; Alex Brandt <alunduil@gentoo.org>
+ +files/remove-argparse-dependence.patch, +unittest2-1.0.1-r1.ebuild:
+ add fixes proposed by Arfrever * RDEPEND and DEPEND on dev-python/setuptools
+ * drop dependence on dev-python/linecache2 * drop sed (suspect return value)
+ and use patch
03 Apr 2015; Mike Frysinger <vapier@gentoo.org> unittest2-0.5.1-r2.ebuild:
Mark arm64/s390/sh stable.
diff --git a/dev-python/unittest2/files/remove-argparse-dependence.patch b/dev-python/unittest2/files/remove-argparse-dependence.patch
new file mode 100644
index 000000000000..36f89fc5f8f6
--- /dev/null
+++ b/dev-python/unittest2/files/remove-argparse-dependence.patch
@@ -0,0 +1,12 @@
+diff -r 8928fb47c3a9 setup.py
+--- a/setup.py Thu Mar 12 15:55:36 2015 +1300
++++ b/setup.py Sun Apr 05 09:06:44 2015 -0500
+@@ -57,7 +57,7 @@
+ # Both install and setup requires - because we read VERSION from within the
+ # package, and the package also exports all the APIs.
+ # six for compat helpers
+-REQUIRES = ['argparse', 'six>=1.4', 'traceback2'],
++REQUIRES = ['six>=1.4', 'traceback2'],
+
+ params = dict(
+ name=NAME,
diff --git a/dev-python/unittest2/unittest2-1.0.1-r1.ebuild b/dev-python/unittest2/unittest2-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..3adb52e53df9
--- /dev/null
+++ b/dev-python/unittest2/unittest2-1.0.1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/unittest2/unittest2-1.0.1-r1.ebuild,v 1.1 2015/04/06 15:19:42 alunduil Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="The new features in unittest for Python 2.7 backported to Python 2.4+"
+HOMEPAGE="http://pypi.python.org/pypi/unittest2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa"
+IUSE=""
+
+CDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/traceback2[${PYTHON_USEDEP}]
+"
+DEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}"
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}"/remove-argparse-dependence.patch
+ )
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" -m unittest2 discover || die "tests failed under ${EPYTHON}"
+}