summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-11-24 02:04:27 +0000
committerTim Harder <radhermit@gentoo.org>2012-11-24 02:04:27 +0000
commitce78eec0c7452b856f27721e2b9a22ed90b2cb68 (patch)
tree3b08443e856c67051ef3f9e904921e4926de42b1 /dev-python/urwid
parentstable arm ppc64, bug #442510 (diff)
downloadgentoo-2-ce78eec0c7452b856f27721e2b9a22ed90b2cb68.tar.gz
gentoo-2-ce78eec0c7452b856f27721e2b9a22ed90b2cb68.tar.bz2
gentoo-2-ce78eec0c7452b856f27721e2b9a22ed90b2cb68.zip
Version bump. Fix html docs build with python-3.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/urwid')
-rw-r--r--dev-python/urwid/ChangeLog8
-rw-r--r--dev-python/urwid/urwid-1.1.0.ebuild10
-rw-r--r--dev-python/urwid/urwid-1.1.1.ebuild57
3 files changed, 71 insertions, 4 deletions
diff --git a/dev-python/urwid/ChangeLog b/dev-python/urwid/ChangeLog
index afccc8dc54bd..6b1691cf3818 100644
--- a/dev-python/urwid/ChangeLog
+++ b/dev-python/urwid/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/urwid
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/ChangeLog,v 1.58 2012/11/05 22:10:00 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/ChangeLog,v 1.59 2012/11/24 02:04:27 radhermit Exp $
+
+*urwid-1.1.1 (24 Nov 2012)
+
+ 24 Nov 2012; Tim Harder <radhermit@gentoo.org> urwid-1.1.0.ebuild,
+ +urwid-1.1.1.ebuild:
+ Version bump. Fix html docs build with python-3.
05 Nov 2012; Tim Harder <radhermit@gentoo.org> urwid-0.9.9.1.ebuild,
urwid-1.0.2.ebuild, urwid-1.1.0.ebuild:
diff --git a/dev-python/urwid/urwid-1.1.0.ebuild b/dev-python/urwid/urwid-1.1.0.ebuild
index d527d6c170b1..4e53373a0090 100644
--- a/dev-python/urwid/urwid-1.1.0.ebuild
+++ b/dev-python/urwid/urwid-1.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/urwid-1.1.0.ebuild,v 1.2 2012/11/05 22:10:00 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/urwid-1.1.0.ebuild,v 1.3 2012/11/24 02:04:27 radhermit Exp $
EAPI="4"
PYTHON_USE_WITH="ncurses"
@@ -30,6 +30,10 @@ src_prepare() {
distutils_src_prepare
epatch "${FILESDIR}"/${P}-sphinx.patch
+
+ if [[ $(python_get_version -f --major) == 3 ]] ; then
+ 2to3-$(PYTHON -f --ABI) -nw --no-diffs docs/conf.py || die
+ fi
}
src_compile() {
@@ -37,14 +41,14 @@ src_compile() {
if use doc ; then
cd docs
- sphinx-build . _build || die
+ PYTHONPATH="$(ls -d ../build-$(PYTHON -f --ABI)/lib*)" sphinx-build . _build/html || die
fi
}
src_install() {
distutils_src_install
- use doc && dohtml -r docs/_build/*
+ use doc && dohtml -r docs/_build/html/*
if use examples ; then
dodoc -r examples
diff --git a/dev-python/urwid/urwid-1.1.1.ebuild b/dev-python/urwid/urwid-1.1.1.ebuild
new file mode 100644
index 000000000000..1d1112e0ca7c
--- /dev/null
+++ b/dev-python/urwid/urwid-1.1.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/urwid-1.1.1.ebuild,v 1.1 2012/11/24 02:04:27 radhermit Exp $
+
+EAPI="5"
+PYTHON_USE_WITH="ncurses"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+PYTHON_TESTS_FAILURES_TOLERANT_ABIS="3.1"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils eutils
+
+DESCRIPTION="Urwid is a curses-based user interface library for Python"
+HOMEPAGE="http://excess.org/urwid/ http://pypi.python.org/pypi/urwid"
+SRC_URI="http://excess.org/urwid/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="doc examples test"
+
+DEPEND="dev-python/setuptools
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/twisted )"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+src_prepare() {
+ distutils_src_prepare
+
+ epatch "${FILESDIR}"/${PN}-1.1.0-sphinx.patch
+
+ if [[ $(python_get_version -f --major) == 3 ]] ; then
+ 2to3-$(PYTHON -f --ABI) -nw --no-diffs docs/conf.py || die
+ fi
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc ; then
+ cd docs
+ PYTHONPATH="$(ls -d ../build-$(PYTHON -f --ABI)/lib*)" sphinx-build . _build/html || die
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ use doc && dohtml -r docs/_build/html/*
+
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}