summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-01-08 05:25:54 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-01-08 05:25:54 +0000
commitcacf54cd771de066cbfeb13899df1fb0d43b6ab2 (patch)
treedc943145f74894525c00c1c7f915083c86722fbb /dev-python/webtest
parentBump (diff)
downloadgentoo-2-cacf54cd771de066cbfeb13899df1fb0d43b6ab2.tar.gz
gentoo-2-cacf54cd771de066cbfeb13899df1fb0d43b6ab2.tar.bz2
gentoo-2-cacf54cd771de066cbfeb13899df1fb0d43b6ab2.zip
Bump
(Portage version: 2.2.8/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/webtest')
-rw-r--r--dev-python/webtest/ChangeLog9
-rw-r--r--dev-python/webtest/webtest-2.0.11.ebuild67
2 files changed, 74 insertions, 2 deletions
diff --git a/dev-python/webtest/ChangeLog b/dev-python/webtest/ChangeLog
index ed727312e0d5..951db0b20c95 100644
--- a/dev-python/webtest/ChangeLog
+++ b/dev-python/webtest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/webtest
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/ChangeLog,v 1.73 2013/11/26 07:33:48 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/ChangeLog,v 1.74 2014/01/08 05:25:54 patrick Exp $
+
+*webtest-2.0.11 (08 Jan 2014)
+
+ 08 Jan 2014; Patrick Lauer <patrick@gentoo.org> +webtest-2.0.11.ebuild:
+ Bump
*webtest-2.0.10 (26 Nov 2013)
diff --git a/dev-python/webtest/webtest-2.0.11.ebuild b/dev-python/webtest/webtest-2.0.11.ebuild
new file mode 100644
index 000000000000..a9b2239d6f34
--- /dev/null
+++ b/dev-python/webtest/webtest-2.0.11.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/webtest-2.0.11.ebuild,v 1.1 2014/01/08 05:25:54 patrick Exp $
+
+EAPI=5
+
+# sigh.
+RESTRICT="test"
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit distutils-r1
+
+MY_PN="WebTest"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Helper to test WSGI applications"
+HOMEPAGE="http://pythonpaste.org/webtest/ http://pypi.python.org/pypi/WebTest"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/waitress-0.8.5[${PYTHON_USEDEP}]
+ >=dev-python/webob-0.9.2[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ python_targets_python2_6? ( dev-python/ordereddict[python_targets_python2_6] )
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pyquery[${PYTHON_USEDEP}]
+ dev-python/wsgiproxy2[${PYTHON_USEDEP}]
+ dev-python/paste
+ dev-python/pastedeploy )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs html || die
+ fi
+}
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ # Why is it so?
+ if [[ ${EPYTHON} == python3* ]]; then
+ rm -f "${D}$(python_get_sitedir)"/webtest/lint3.py
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( html/. )
+ distutils-r1_python_install_all
+}