summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-03-19 15:39:16 +0000
committerIan Delaney <idella4@gentoo.org>2013-03-19 15:39:16 +0000
commita214059ae153281e08d005f72b5b390345511cc3 (patch)
tree57be763a3d1b16e4df67f1a0d87f75dabedf81bb /dev-python/workerpool
parentVersion bump, restrict llvm version due to upstream #1157158. (diff)
downloadgentoo-2-a214059ae153281e08d005f72b5b390345511cc3.tar.gz
gentoo-2-a214059ae153281e08d005f72b5b390345511cc3.tar.bz2
gentoo-2-a214059ae153281e08d005f72b5b390345511cc3.zip
migration revbump
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/workerpool')
-rw-r--r--dev-python/workerpool/ChangeLog9
-rw-r--r--dev-python/workerpool/workerpool-0.9.2-r1.ebuild33
2 files changed, 40 insertions, 2 deletions
diff --git a/dev-python/workerpool/ChangeLog b/dev-python/workerpool/ChangeLog
index 0079c80f1d43..b9bc3cda87a2 100644
--- a/dev-python/workerpool/ChangeLog
+++ b/dev-python/workerpool/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/workerpool
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/workerpool/ChangeLog,v 1.4 2012/11/13 10:22:08 idella4 Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/workerpool/ChangeLog,v 1.5 2013/03/19 15:39:16 idella4 Exp $
+
+*workerpool-0.9.2-r1 (19 Mar 2013)
+
+ 19 Mar 2013; Ian Delaney <idella4@gentoo.org> +workerpool-0.9.2-r1.ebuild:
+ migration revbump
14 Nov 2012; Ian Delaney <idella4@gentoo.org> metadata.xml:
Updating maintainer, metadata.xml
diff --git a/dev-python/workerpool/workerpool-0.9.2-r1.ebuild b/dev-python/workerpool/workerpool-0.9.2-r1.ebuild
new file mode 100644
index 000000000000..a712c2c1f119
--- /dev/null
+++ b/dev-python/workerpool/workerpool-0.9.2-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/workerpool/workerpool-0.9.2-r1.ebuild,v 1.1 2013/03/19 15:39:16 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_{5,6,7} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for distributing jobs to a pool of worker threads."
+HOMEPAGE="http://github.com/shazow/workerpool"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test examples"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+python_test() {
+ nosetests -v test || die
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x usr/share/doc/${P}/samples
+ insinto usr/share/doc/${P}/
+ doins -r samples
+ fi
+}