summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-05-20 08:12:48 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-05-20 08:12:48 +0000
commitfd3c72be61fc5eeab1d2a26a9433291f7437b0fd (patch)
tree6bae784ccffaedbac45069712519fea1715d591c /dev-python/wtf-peewee
parentBump (diff)
downloadgentoo-2-fd3c72be61fc5eeab1d2a26a9433291f7437b0fd.tar.gz
gentoo-2-fd3c72be61fc5eeab1d2a26a9433291f7437b0fd.tar.bz2
gentoo-2-fd3c72be61fc5eeab1d2a26a9433291f7437b0fd.zip
Bump
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/wtf-peewee')
-rw-r--r--dev-python/wtf-peewee/ChangeLog7
-rw-r--r--dev-python/wtf-peewee/wtf-peewee-0.2.1.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-python/wtf-peewee/ChangeLog b/dev-python/wtf-peewee/ChangeLog
index 2adb5a728d84..7c8985f7cf62 100644
--- a/dev-python/wtf-peewee/ChangeLog
+++ b/dev-python/wtf-peewee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/wtf-peewee
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wtf-peewee/ChangeLog,v 1.4 2014/05/03 08:03:02 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wtf-peewee/ChangeLog,v 1.5 2014/05/20 08:12:48 patrick Exp $
+
+*wtf-peewee-0.2.1 (20 May 2014)
+
+ 20 May 2014; Patrick Lauer <patrick@gentoo.org> +wtf-peewee-0.2.1.ebuild:
+ Bump
*wtf-peewee-0.2.0 (03 May 2014)
diff --git a/dev-python/wtf-peewee/wtf-peewee-0.2.1.ebuild b/dev-python/wtf-peewee/wtf-peewee-0.2.1.ebuild
new file mode 100644
index 000000000000..27372682f6dd
--- /dev/null
+++ b/dev-python/wtf-peewee/wtf-peewee-0.2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wtf-peewee/wtf-peewee-0.2.1.ebuild,v 1.1 2014/05/20 08:12:48 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+RESTRICT="test" # broken
+
+DESCRIPTION="Small python ORM"
+HOMEPAGE="https://github.com/coleifer/peewee/"
+SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/peewee[${PYTHON_USEDEP}]
+ dev-python/wtforms[${PYTHON_USEDEP}]
+ "
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}