summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-03-10 07:12:39 +0000
committerIan Delaney <idella4@gentoo.org>2013-03-10 07:12:39 +0000
commit3b63ee86ea23090b759fc9565728a0b5238ef062 (patch)
tree9d5428edd13c0467dacdc8d64ef15248706b3536 /dev-python/xlrd
parentVersion bump. (diff)
downloadgentoo-2-3b63ee86ea23090b759fc9565728a0b5238ef062.tar.gz
gentoo-2-3b63ee86ea23090b759fc9565728a0b5238ef062.tar.bz2
gentoo-2-3b63ee86ea23090b759fc9565728a0b5238ef062.zip
bump
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/xlrd')
-rw-r--r--dev-python/xlrd/ChangeLog7
-rw-r--r--dev-python/xlrd/xlrd-0.9.0.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-python/xlrd/ChangeLog b/dev-python/xlrd/ChangeLog
index 6034beb3af51..612253b38039 100644
--- a/dev-python/xlrd/ChangeLog
+++ b/dev-python/xlrd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/xlrd
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/xlrd/ChangeLog,v 1.9 2013/02/18 11:06:07 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/xlrd/ChangeLog,v 1.10 2013/03/10 07:12:39 idella4 Exp $
+
+*xlrd-0.9.0 (10 Mar 2013)
+
+ 10 Mar 2013; Ian Delaney <idella4@gentoo.org> +xlrd-0.9.0.ebuild:
+ bump
18 Feb 2013; Agostino Sarubbo <ago@gentoo.org> xlrd-0.8.0.ebuild:
Stable for x86, wrt bug #458072
diff --git a/dev-python/xlrd/xlrd-0.9.0.ebuild b/dev-python/xlrd/xlrd-0.9.0.ebuild
new file mode 100644
index 000000000000..badb4a489ae2
--- /dev/null
+++ b/dev-python/xlrd/xlrd-0.9.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/xlrd/xlrd-0.9.0.ebuild,v 1.1 2013/03/10 07:12:39 idella4 Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for developers to extract data from Microsoft Excel (tm) spreadsheet files"
+HOMEPAGE="http://pypi.python.org/pypi/xlrd"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-aix ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ distutils-r1_src_prepare
+ # add shebang to runxlrd.py
+ sed -i -e '1i#!/usr/bin/encompdoc.html xlrd.htmlv python' scripts/runxlrd.py || die
+}
+
+python_install_all() {
+ if use doc; then
+ dohtml ${PN}/doc/{compdoc.html,xlrd.html}
+ fi
+
+ if use examples; then
+ docompress -x usr/share/doc/${P}/examples/
+ insinto usr/share/doc/${P}/examples
+ doins ${PN}/examples/*
+ fi
+}