summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-01-09 05:16:51 +0000
committerIan Delaney <idella4@gentoo.org>2015-01-09 05:16:51 +0000
commit0453f0e8468e50efa1243a4e0266cd3b68a9bb19 (patch)
treee3dcc00265e9fe9b5f2da808f80f61ef952270ee /dev-python
parentVersion bump (diff)
downloadgentoo-2-0453f0e8468e50efa1243a4e0266cd3b68a9bb19.tar.gz
gentoo-2-0453f0e8468e50efa1243a4e0266cd3b68a9bb19.tar.bz2
gentoo-2-0453f0e8468e50efa1243a4e0266cd3b68a9bb19.zip
revbump; conversion -> distutils-r1
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sancho/ChangeLog10
-rw-r--r--dev-python/sancho/sancho-2.4-r1.ebuild44
2 files changed, 51 insertions, 3 deletions
diff --git a/dev-python/sancho/ChangeLog b/dev-python/sancho/ChangeLog
index ca6271e0fc45..1e2c11314bc4 100644
--- a/dev-python/sancho/ChangeLog
+++ b/dev-python/sancho/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/sancho
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sancho/ChangeLog,v 1.47 2010/06/29 04:45:57 arfrever Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sancho/ChangeLog,v 1.48 2015/01/09 05:16:51 idella4 Exp $
+
+*sancho-2.4-r1 (09 Jan 2015)
+
+ 09 Jan 2015; Ian Delaney <idella4@gentoo.org> +sancho-2.4-r1.ebuild:
+ revbump; conversion -> distutils-r1
29 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
sancho-2.4.ebuild:
@@ -159,4 +164,3 @@
+sancho-2.1.ebuild:
Initial commit. Ebuild by Robin H. Johnson <robbat2@gentoo.org>. Needed for
pycrypto testcases.
-
diff --git a/dev-python/sancho/sancho-2.4-r1.ebuild b/dev-python/sancho/sancho-2.4-r1.ebuild
new file mode 100644
index 000000000000..8699976f2d59
--- /dev/null
+++ b/dev-python/sancho/sancho-2.4-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sancho/sancho-2.4-r1.ebuild,v 1.1 2015/01/09 05:16:51 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_P="Sancho-${PV}"
+
+DESCRIPTION="Sancho is a unit testing framework"
+HOMEPAGE="http://www.mems-exchange.org/software/sancho/"
+SRC_URI="http://www.mems-exchange.org/software/files/${PN}/${MY_P}.tar.gz"
+
+LICENSE="CNRI"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ cd test
+ local test test_failure test_failure_count=0
+ for test in *.py; do
+ test_failure="0"
+ ebegin "Testing ${test}"
+ "${PYTHON}" "${test}" > "${test}.output"
+ grep -Eqv "^${test}: .*:$" "${test}.output" && test_failure="1"
+ eend "${test_failure}"
+ if [[ "${test_failure}" == "1" ]]; then
+ ((test_failure_count++))
+ eerror "Failure output for ${test}"
+ cat "${test}.output"
+ fi
+ done
+ if [[ "${test_failure_count}" -gt "0" ]]; then
+ die "${test_failure_count} tests failed"
+ fi
+}