summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2014-06-06 15:44:16 +0000
committerDirkjan Ochtman <djc@gentoo.org>2014-06-06 15:44:16 +0000
commit2cf617e575979b44083f8754756d4a1626e77057 (patch)
tree2a7ff137dd678e631c478162074849dbcf9d12f0 /dev-python
parentbump; drop py2.6 add py3.3 support, upgrade of test phase (diff)
downloadgentoo-2-2cf617e575979b44083f8754756d4a1626e77057.tar.gz
gentoo-2-2cf617e575979b44083f8754756d4a1626e77057.tar.bz2
gentoo-2-2cf617e575979b44083f8754756d4a1626e77057.zip
Version bump bottle to 0.11.7 (fixes bug 509350)
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 30380381)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/bottle/ChangeLog7
-rw-r--r--dev-python/bottle/bottle-0.11.7.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-python/bottle/ChangeLog b/dev-python/bottle/ChangeLog
index 4236a3fed9b5..62fd929622ff 100644
--- a/dev-python/bottle/ChangeLog
+++ b/dev-python/bottle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/bottle
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bottle/ChangeLog,v 1.23 2014/05/15 12:58:36 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bottle/ChangeLog,v 1.24 2014/06/06 15:44:16 djc Exp $
+
+*bottle-0.11.7 (06 Jun 2014)
+
+ 06 Jun 2014; Dirkjan Ochtman <djc@gentoo.org> +bottle-0.11.7.ebuild:
+ Version bump bottle to 0.11.7 (fixes bug 509350)
15 May 2014; Ian Delaney <idella4@gentoo.org> bottle-0.12.5.ebuild:
drop py2.6 pypy2_0 add py3.4 support
diff --git a/dev-python/bottle/bottle-0.11.7.ebuild b/dev-python/bottle/bottle-0.11.7.ebuild
new file mode 100644
index 000000000000..d3cad5b8afbd
--- /dev/null
+++ b/dev-python/bottle/bottle-0.11.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bottle/bottle-0.11.7.ebuild,v 1.1 2014/06/06 15:44:16 djc Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy pypy2_0)
+inherit distutils-r1
+
+DESCRIPTION="A fast and simple micro-framework for small web-applications"
+HOMEPAGE="http://pypi.python.org/pypi/bottle http://bottlepy.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+python_prepare_all() {
+ sed -i -e '/scripts/d' setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ elog "Due to problems with bottle.py being in /usr/bin (see bug #474874)"
+ elog "we do as most other distros and do not install the script anymore."
+ elog "If you do want/have to call it directly rather than through your app,"
+ elog "please use the following instead:"
+ elog ' `python -m bottle`'
+}