summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-25 21:12:43 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-25 21:12:43 +0000
commit361f4e9772cdcf2af7d006fa555db90e90e134ff (patch)
tree1dae3cd62fd5717bd25e054a0b664c1a0164c177 /dev-python
parentstable amd64, bug 319521 (diff)
downloadgentoo-2-361f4e9772cdcf2af7d006fa555db90e90e134ff.tar.gz
gentoo-2-361f4e9772cdcf2af7d006fa555db90e90e134ff.tar.bz2
gentoo-2-361f4e9772cdcf2af7d006fa555db90e90e134ff.zip
Version bump.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/logilab-common/ChangeLog8
-rw-r--r--dev-python/logilab-common/logilab-common-0.50.2.ebuild85
2 files changed, 92 insertions, 1 deletions
diff --git a/dev-python/logilab-common/ChangeLog b/dev-python/logilab-common/ChangeLog
index c3f0bc07c9e8..790402686b0a 100644
--- a/dev-python/logilab-common/ChangeLog
+++ b/dev-python/logilab-common/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/logilab-common
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/ChangeLog,v 1.64 2010/05/22 13:52:06 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/ChangeLog,v 1.65 2010/05/25 21:12:43 arfrever Exp $
+
+*logilab-common-0.50.2 (25 May 2010)
+
+ 25 May 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +logilab-common-0.50.2.ebuild:
+ Version bump.
22 May 2010; Pacho Ramos <pacho@gentoo.org> logilab-common-0.49.0.ebuild:
stable amd64, bug 300245
diff --git a/dev-python/logilab-common/logilab-common-0.50.2.ebuild b/dev-python/logilab-common/logilab-common-0.50.2.ebuild
new file mode 100644
index 000000000000..bc7af049a48e
--- /dev/null
+++ b/dev-python/logilab-common/logilab-common-0.50.2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/logilab-common-0.50.2.ebuild,v 1.1 2010/05/25 21:12:43 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils
+
+DESCRIPTION="Useful miscellaneous modules used by Logilab projects"
+HOMEPAGE="http://www.logilab.org/projects/common/ http://pypi.python.org/pypi/logilab-common"
+SRC_URI="ftp://ftp.logilab.org/pub/common/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="test"
+
+# Tests using dev-python/psycopg are skipped when dev-python/psycopg isn't installed.
+DEPEND="test? (
+ dev-python/egenix-mx-base
+ !dev-python/psycopg[-mxdatetime]
+ )"
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
+
+PYTHON_MODNAME="logilab"
+# Extra documentation (html/pdf) needs some love
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Disable broken test.
+ sed -e "s/test_knownValues_is_standard_module_4/_&/" -i test/unittest_modutils.py
+
+ # Disable tests failing when stdout is not a tty.
+ sed \
+ -e "s/test_both_capture/_&/" \
+ -e "s/test_capture_core/_&/" \
+ -i test/unittest_testlib.py
+
+ if [[ "${EUID}" -eq 0 ]]; then
+ # Disable tests failing with root permissions.
+ sed \
+ -e "s/test_mode_change/_&/" \
+ -e "s/test_mode_change_on_append/_&/" \
+ -e "s/test_restore_on_close/_&/" \
+ -i test/unittest_fileutils.py
+ fi
+}
+
+src_test() {
+ testing() {
+ # Install temporarily.
+ local tpath="${T}/test-${PYTHON_ABI}"
+ local spath="${tpath}$(python_get_sitedir)"
+
+ "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install --root="${tpath}" || die "Installation for tests failed with Python ${PYTHON_ABI}"
+
+ # Bug 223079.
+ if [[ "${EUID}" -eq 0 ]]; then
+ rm test/unittest_fileutils.py || die
+ fi
+
+ # pytest picks up the tests relative to the current directory, so cd in. Do
+ # not cd in too far though (to logilab/common for example) or some
+ # relative/absolute module location tests fail.
+ pushd "${spath}" >/dev/null || die
+ PYTHONPATH="${spath}" "$(PYTHON)" "${tpath}/usr/bin/pytest" -v || return 1
+ popd >/dev/null || die
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ python_generate_wrapper_scripts -E -f -q "${ED}usr/bin/pytest"
+
+ doman doc/pytest.1 || die "doman failed"
+
+ # Don't install tests.
+ rm -fr "${ED}"usr/lib*/python*/site-packages/${PN/-//}/test || die "Deletion of tests failed"
+}