summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-21 23:51:25 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-21 23:51:25 +0000
commit5cb1ee7fa8c6e1f1ffa67a0971377d51068b3c44 (patch)
tree7825d9d10acd801ea171d13b5cf9152f16087e73 /dev-python
parentVersion bump. (diff)
downloadgentoo-2-5cb1ee7fa8c6e1f1ffa67a0971377d51068b3c44.tar.gz
gentoo-2-5cb1ee7fa8c6e1f1ffa67a0971377d51068b3c44.tar.bz2
gentoo-2-5cb1ee7fa8c6e1f1ffa67a0971377d51068b3c44.zip
Use nosetests directly. Update HOMEPAGE.
(Portage version: 2.2.0_alpha30_p1/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/flask-script/flask-script-0.3.1.ebuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/dev-python/flask-script/flask-script-0.3.1.ebuild b/dev-python/flask-script/flask-script-0.3.1.ebuild
index d6b79e9c1e57..e2071e8e0005 100644
--- a/dev-python/flask-script/flask-script-0.3.1.ebuild
+++ b/dev-python/flask-script/flask-script-0.3.1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-script/flask-script-0.3.1.ebuild,v 1.2 2010/12/14 23:25:13 rafaelmartins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask-script/flask-script-0.3.1.ebuild,v 1.3 2011/04/21 23:51:25 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.*"
-DISTUTILS_SRC_TEST="setup.py"
+DISTUTILS_SRC_TEST="nosetests"
inherit distutils
@@ -14,20 +14,19 @@ MY_PN="Flask-Script"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="Flask support for writing external scripts."
-HOMEPAGE="http://packages.python.org/Flask-Script/"
+HOMEPAGE="http://packages.python.org/Flask-Script/ http://pypi.python.org/pypi/Flask-Script"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
+IUSE="doc"
RDEPEND="dev-python/flask
dev-python/argparse"
DEPEND="${RDEPEND}
dev-python/setuptools
- doc? ( dev-python/sphinx )
- test? ( dev-python/nose )"
+ doc? ( dev-python/sphinx )"
S="${WORKDIR}/${MY_P}"
@@ -38,8 +37,7 @@ src_compile() {
if use doc; then
einfo "Generation of documentation"
- PYTHONPATH="${S}" emake -C docs html \
- || die "Generation of documentation failed"
+ PYTHONPATH=".." emake -C docs html || die "Generation of documentation failed"
fi
}