summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-03-24 05:34:50 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-03-24 05:34:50 +0000
commit5fc54e1b5ca9e7c1afa9ccdb864d19216bb365df (patch)
treee1ca97c1d4e2b6c71f103b20a0611b5a727292e1 /dev-python
parentDisable ar test for this version (bug #310847). (diff)
downloadgentoo-2-5fc54e1b5ca9e7c1afa9ccdb864d19216bb365df.tar.gz
gentoo-2-5fc54e1b5ca9e7c1afa9ccdb864d19216bb365df.tar.bz2
gentoo-2-5fc54e1b5ca9e7c1afa9ccdb864d19216bb365df.zip
Added proper patch this time and updated docs
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/enable/ChangeLog6
-rw-r--r--dev-python/enable/enable-3.3.0.ebuild29
-rw-r--r--dev-python/enable/files/enable-3.3.0-nofreetype.patch127
3 files changed, 153 insertions, 9 deletions
diff --git a/dev-python/enable/ChangeLog b/dev-python/enable/ChangeLog
index 4218d0296074..44316d3ad9dd 100644
--- a/dev-python/enable/ChangeLog
+++ b/dev-python/enable/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/enable
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/enable/ChangeLog,v 1.5 2010/03/23 05:10:59 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/enable/ChangeLog,v 1.6 2010/03/24 05:34:49 bicatali Exp $
+
+ 24 Mar 2010; Sébastien Fabbro <bicatali@gentoo.org> enable-3.3.0.ebuild,
+ +files/enable-3.3.0-nofreetype.patch:
+ Added proper patch this time and updated docs
*enable-3.3.0 (21 Mar 2010)
diff --git a/dev-python/enable/enable-3.3.0.ebuild b/dev-python/enable/enable-3.3.0.ebuild
index bbb465ddd3a6..b9a5376d0ebe 100644
--- a/dev-python/enable/enable-3.3.0.ebuild
+++ b/dev-python/enable/enable-3.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/enable/enable-3.3.0.ebuild,v 1.1 2010/03/23 05:10:59 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/enable/enable-3.3.0.ebuild,v 1.2 2010/03/24 05:34:49 bicatali Exp $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
@@ -13,8 +13,7 @@ DESCRIPTION="Enthought Tool Suite drawing and interaction GUI objects"
HOMEPAGE="http://code.enthought.com/projects/enable"
SRC_URI="http://www.enthought.com/repo/ETS/${MY_P}.tar.gz"
-IUSE="examples"
-#IUSE="examples test"
+IUSE="doc examples"
SLOT="0"
KEYWORDS="~amd64 ~x86"
LICENSE="BSD"
@@ -32,7 +31,8 @@ DEPEND="dev-python/setuptools
virtual/glu
x11-libs/libX11
dev-lang/swig
- dev-python/pyrex"
+ dev-python/pyrex
+ doc? ( dev-python/setupdocs )"
RESTRICT_PYTHON_ABIS="3.*"
# tests need X with wxpython
# test? ( >=dev-python/nose-0.10.3
@@ -44,11 +44,19 @@ S="${WORKDIR}/${MY_P}"
PYTHON_MODNAME="enthought"
-DOCS="CHANGELOG.txt"
-
src_prepare() {
- epatch "${FILESDIR}/${PN}-3.0.2-nofreetype.patch"
- sed -i -e "/self.run_command('build_docs')/d" setup.py || die
+ sed -i \
+ -e "s/self.run_command('build_docs')/pass/" \
+ -e "s/setupdocs>=1.0//" \
+ setup.py || die
+ epatch "${FILESDIR}"/${P}-nofreetype.patch
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ "$(PYTHON -f)" setup.py build_docs --formats=html,pdf || die "Generation of documentation failed"
+ fi
}
src_test() {
@@ -61,7 +69,12 @@ src_test() {
src_install() {
find "${S}" -name \*LICENSE.txt -delete
distutils_src_install
+ dodoc docs/*.txt
insinto /usr/share/doc/${PF}
+ if use doc; then
+ doins -r build/docs/html || die
+ doins docs/latex/*.pdf || die
+ fi
if use examples; then
doins -r examples || die
fi
diff --git a/dev-python/enable/files/enable-3.3.0-nofreetype.patch b/dev-python/enable/files/enable-3.3.0-nofreetype.patch
new file mode 100644
index 000000000000..56000986dff5
--- /dev/null
+++ b/dev-python/enable/files/enable-3.3.0-nofreetype.patch
@@ -0,0 +1,127 @@
+--- Enable-3.3.0.orig/enthought/kiva/agg/setup.py 2010-02-25 13:15:07.000000000 -0500
++++ Enable-3.3.0/enthought/kiva/agg/setup.py 2010-03-21 14:55:37.000000000 -0500
+@@ -4,59 +4,6 @@
+ import re
+ import platform
+
+-freetype2_sources =['autofit/autofit.c',
+- 'base/ftbase.c','base/ftsystem.c','base/ftinit.c',
+- 'base/ftglyph.c','base/ftmm.c','base/ftbdf.c',
+- 'base/ftbbox.c','base/ftdebug.c','base/ftxf86.c',
+- 'base/fttype1.c',
+- 'bdf/bdf.c',
+- 'cff/cff.c',
+- 'cid/type1cid.c',
+- 'lzw/ftlzw.c',
+- 'pcf/pcf.c','pfr/pfr.c',
+- 'psaux/psaux.c',
+- 'pshinter/pshinter.c',
+- 'psnames/psnames.c',
+- 'raster/raster.c',
+- 'sfnt/sfnt.c',
+- 'smooth/smooth.c',
+- 'truetype/truetype.c',
+- 'type1/type1.c',
+- 'type42/type42.c',
+- 'winfonts/winfnt.c',
+- 'gzip/ftgzip.c',
+- 'base/ftmac.c',
+- ]
+-
+-freetype2_dirs = [
+- 'autofit',
+- 'base',
+- 'bdf',
+- 'cache',
+- 'cff',
+- 'cid',
+- 'gxvalid',
+- 'gzip',
+- 'lzw',
+- 'otvalid',
+- 'pcf',
+- 'pfr',
+- 'psaux',
+- 'pshinter',
+- 'psnames',
+- 'raster',
+- 'sfnt',
+- 'smooth',
+- 'tools',
+- 'truetype',
+- 'type1',
+- 'type42',
+- 'winfonts',
+- 'gzip'
+- ]
+-
+-
+-
+ def configuration(parent_package='',top_path=None):
+ from numpy.distutils.misc_util import Configuration
+ from numpy.distutils.system_info import dict_append, get_info
+@@ -85,45 +32,11 @@
+ plat = 'x11' # use with gtk2, it's slow but reliable
+ #plat = 'gdkpixbuf2'
+
+-
+- #-------------------------------------------------------------------------
+- # Add the freetype library (agg 2.4 links against this)
+- #-------------------------------------------------------------------------
+-
+- prefix = config.paths('freetype2/src')[0]
+- freetype_lib = 'freetype2_src'
+-
+- def get_ft2_sources((lib_name, build_info), build_dir):
+- sources = [prefix + "/" + s for s in freetype2_sources]
+- if sys.platform=='darwin':
+- return sources[:]
+- return sources[:-1]
+-
+- ft2_incl_dirs = ['freetype2/src/' + s for s in freetype2_dirs] \
+- + ['freetype2/include', 'freetype2/src']
+- ft2_incl_dirs = config.paths(*ft2_incl_dirs)
+- if sys.platform == 'darwin':
+- ft2_incl_dirs.append("/Developer/Headers/FlatCarbon")
+-
+- config.add_library(freetype_lib,
+- sources = [get_ft2_sources],
+- include_dirs = ft2_incl_dirs,
+-
+- # This macro was introduced in Freetype 2.2; if it is
+- # not defined, then the ftheader.h file (one of the
+- # primary headers) won't pull in any additional internal
+- # Freetype headers, and the library will mysteriously
+- # fail to build.
+- macros = [("FT2_BUILD_LIBRARY", None)],
+-
+- depends = ['freetype2'],
+- )
+-
+ #-------------------------------------------------------------------------
+ # Add the Agg sources
+ #-------------------------------------------------------------------------
+
+- agg_include_dirs = [agg_dir+'/include',agg_dir+'/font_freetype'] + ft2_incl_dirs
++ agg_include_dirs = [agg_dir+'/include',agg_dir+'/font_freetype'] + ["/usr/include/freetype2/"]
+ agg_sources = [agg_dir+'/src/*.cpp',
+ agg_dir+'/font_freetype/*.cpp']
+ config.add_library(agg_lib,
+@@ -137,7 +50,7 @@
+ if sys.platform == 'darwin':
+ define_macros = [('__DARWIN__', None)]
+ macros = [('__DARWIN__', None)]
+- extra_link_args = ['-framework', 'Carbon']
++ extra_link_args = ['-framework', 'Carbon', '-Wl,-search_paths_first']
+ else:
+ define_macros = []
+ macros = []
+@@ -191,7 +104,7 @@
+
+ build_info = {}
+ kiva_lib = 'kiva_src'
+- build_libraries = [kiva_lib, agg_lib, freetype_lib]
++ build_libraries = [kiva_lib, agg_lib, "freetype"]
+ if sys.platform == "win32":
+ build_libraries += ["opengl32", "glu32"]
+ elif sys.platform == "darwin":