summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-03-27 23:03:30 +0000
committerBen de Groot <yngwin@gentoo.org>2009-03-27 23:03:30 +0000
commita2633e412d0a47ba06ca340e99b18bb9247c0c35 (patch)
tree7a1f33cef3ddd95d5f7df1dcb26efc5e40cc747b /dev-python
parentStable for HPPA (bug #260597). (diff)
downloadgentoo-2-a2633e412d0a47ba06ca340e99b18bb9247c0c35.tar.gz
gentoo-2-a2633e412d0a47ba06ca340e99b18bb9247c0c35.tar.bz2
gentoo-2-a2633e412d0a47ba06ca340e99b18bb9247c0c35.zip
Remove old versions
(Portage version: 2.2_rc27/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/qscintilla-python/ChangeLog7
-rw-r--r--dev-python/qscintilla-python/files/qscintilla-python-2.1-nostrip.patch32
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.1.ebuild67
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.2.ebuild65
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.3.ebuild65
5 files changed, 6 insertions, 230 deletions
diff --git a/dev-python/qscintilla-python/ChangeLog b/dev-python/qscintilla-python/ChangeLog
index d53bb0f28c6d..7180717b4f84 100644
--- a/dev-python/qscintilla-python/ChangeLog
+++ b/dev-python/qscintilla-python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/qscintilla-python
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/ChangeLog,v 1.21 2009/03/07 20:28:35 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/ChangeLog,v 1.22 2009/03/27 23:03:30 yngwin Exp $
+
+ 27 Mar 2009; Ben de Groot <yngwin@gentoo.org>
+ -files/qscintilla-python-2.1-nostrip.patch, -qscintilla-python-2.1.ebuild,
+ -qscintilla-python-2.2.ebuild, -qscintilla-python-2.3.ebuild:
+ Remove old versions
*qscintilla-python-2.3.2-r1 (07 Mar 2009)
diff --git a/dev-python/qscintilla-python/files/qscintilla-python-2.1-nostrip.patch b/dev-python/qscintilla-python/files/qscintilla-python-2.1-nostrip.patch
deleted file mode 100644
index a689d868a922..000000000000
--- a/dev-python/qscintilla-python/files/qscintilla-python-2.1-nostrip.patch
+++ /dev/null
@@ -1,32 +0,0 @@
---- configure.py 2007-06-01 20:10:16.000000000 +0300
-+++ configure.py 2007-12-04 11:51:56.000000000 +0200
-@@ -229,7 +229,8 @@
- installs=installs,
- static=opt_static,
- debug=opt_debug,
-- universal=pyqt.universal
-+ universal=pyqt.universal,
-+ strip=0
- )
- elif pyqt.pyqt_version >= 0x040000:
- makefile = pyqt4.QtGuiModuleMakefile(
-@@ -238,7 +239,8 @@
- install_dir=opt_qscimoddir,
- installs=installs,
- static=opt_static,
-- debug=opt_debug
-+ debug=opt_debug,
-+ strip=0
- )
- else:
- makefile = pyqt3.QtModuleMakefile(
-@@ -247,7 +249,8 @@
- install_dir=opt_qscimoddir,
- installs=installs,
- static=opt_static,
-- debug=opt_debug
-+ debug=opt_debug,
-+ strip=0
- )
-
- makefile.extra_include_dirs.append(opt_qsciincdir)
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.1.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.1.ebuild
deleted file mode 100644
index 0c2333fd460c..000000000000
--- a/dev-python/qscintilla-python/qscintilla-python-2.1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/qscintilla-python-2.1.ebuild,v 1.8 2008/10/27 11:51:13 hawking Exp $
-
-inherit eutils python
-
-MY_PN="qscintilla"
-SCINTILLA_VER="1.73"
-MY_P="${MY_PN/qs/QS}-${SCINTILLA_VER}-gpl-${PV}"
-
-DESCRIPTION="Python bindings for Qscintilla"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/qscintilla/"
-SRC_URI="http://www.riverbankcomputing.com/Downloads/QScintilla2/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ~hppa ia64 ~ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="qt4"
-
-DEPEND=">=dev-python/sip-4.4
- =x11-libs/qscintilla-${PV}*
- !<x11-libs/qscintilla-2.1-r1
- qt4? ( dev-python/PyQt4 )
- !qt4? ( dev-python/PyQt )"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${MY_P}/Python
-
-pkg_setup() {
- # this package needs to have same qt flags with qscintilla.
- if use qt4; then
- if ! built_with_use 'x11-libs/qscintilla' 'qt4'; then
- eerror "Please build qscintilla with qt4 useflag."
- die "qscintilla built without qt4."
- fi
- else
- if built_with_use 'x11-libs/qscintilla' 'qt4'; then
- eerror "Please build qscintilla without qt4 useflag."
- die "qscintilla built with qt4"
- fi
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${P}-nostrip.patch
-}
-
-src_compile() {
- local myconf="-o /usr/lib -n /usr/include"
- if use qt4; then
- myconf="${myconf} -p 4"
- else
- myconf="${myconf} -p 3"
- fi
-
- python_version
- ${python} configure.py ${myconf} || die "configure.py failed"
- emake || die "emake failed"
-}
-
-src_install() {
- python_need_rebuild
- emake DESTDIR="${D}" install || die "emake install failed"
-}
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.2.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.2.ebuild
deleted file mode 100644
index af1a3e640d75..000000000000
--- a/dev-python/qscintilla-python/qscintilla-python-2.2.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/qscintilla-python-2.2.ebuild,v 1.2 2008/10/27 11:51:13 hawking Exp $
-
-inherit eutils python
-
-MY_PN="qscintilla"
-MY_P="${MY_PN/qs/QS}-gpl-${PV}"
-
-DESCRIPTION="Python bindings for Qscintilla"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/qscintilla/intro"
-SRC_URI="http://www.riverbankcomputing.com/static/Downloads/QScintilla2/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="qt4"
-
-DEPEND=">=dev-python/sip-4.4
- =x11-libs/qscintilla-${PV}*
- qt4? ( dev-python/PyQt4 )
- !qt4? ( dev-python/PyQt )"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${MY_P}/Python
-
-pkg_setup() {
- # this package needs to have same qt flags with qscintilla.
- if use qt4; then
- if ! built_with_use 'x11-libs/qscintilla' 'qt4'; then
- eerror "Please build qscintilla with qt4 useflag."
- die "qscintilla built without qt4."
- fi
- else
- if built_with_use 'x11-libs/qscintilla' 'qt4'; then
- eerror "Please build qscintilla without qt4 useflag."
- die "qscintilla built with qt4"
- fi
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${P}-nostrip.patch
-}
-
-src_compile() {
- local myconf="-o /usr/lib -n /usr/include"
- if use qt4; then
- myconf="${myconf} -p 4"
- else
- myconf="${myconf} -p 3"
- fi
-
- python_version
- ${python} configure.py ${myconf} || die "configure.py failed"
- emake || die "emake failed"
-}
-
-src_install() {
- python_need_rebuild
- emake DESTDIR="${D}" install || die "emake install failed"
-}
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.3.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.3.ebuild
deleted file mode 100644
index 09c7fd774ce4..000000000000
--- a/dev-python/qscintilla-python/qscintilla-python-2.3.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/qscintilla-python-2.3.ebuild,v 1.2 2008/10/27 11:51:13 hawking Exp $
-
-inherit eutils python
-
-MY_PN="qscintilla"
-MY_P="${MY_PN/qs/QS}-gpl-${PV}"
-
-DESCRIPTION="Python bindings for Qscintilla"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/qscintilla/intro"
-SRC_URI="http://www.riverbankcomputing.com/static/Downloads/QScintilla2/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="qt4"
-
-DEPEND=">=dev-python/sip-4.4
- =x11-libs/qscintilla-${PV}*
- qt4? ( dev-python/PyQt4 )
- !qt4? ( dev-python/PyQt )"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${MY_P}/Python
-
-pkg_setup() {
- # this package needs to have same qt flags with qscintilla.
- if use qt4; then
- if ! built_with_use 'x11-libs/qscintilla' 'qt4'; then
- eerror "Please build qscintilla with qt4 useflag."
- die "qscintilla built without qt4."
- fi
- else
- if built_with_use 'x11-libs/qscintilla' 'qt4'; then
- eerror "Please build qscintilla without qt4 useflag."
- die "qscintilla built with qt4"
- fi
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${PN}-2.2-nostrip.patch
-}
-
-src_compile() {
- local myconf="-o /usr/lib -n /usr/include"
- if use qt4; then
- myconf="${myconf} -p 4"
- else
- myconf="${myconf} -p 3"
- fi
-
- python_version
- ${python} configure.py ${myconf} || die "configure.py failed"
- emake || die "emake failed"
-}
-
-src_install() {
- python_need_rebuild
- emake DESTDIR="${D}" install || die "emake install failed"
-}