summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2006-09-27 00:08:04 +0000
committerMarien Zwart <marienz@gentoo.org>2006-09-27 00:08:04 +0000
commitb3c34d93f5fe6eb5c81897ac33cd40bccf646c50 (patch)
tree84a4f6e3cb3b7e58d894d8a0cbf9ef8aee981289 /dev-python
parentAdd missing IUSE. (diff)
downloadgentoo-2-b3c34d93f5fe6eb5c81897ac33cd40bccf646c50.tar.gz
gentoo-2-b3c34d93f5fe6eb5c81897ac33cd40bccf646c50.tar.bz2
gentoo-2-b3c34d93f5fe6eb5c81897ac33cd40bccf646c50.zip
Version bump for bug #148865 and #148422.
(Portage version: 2.1.2_pre1-r2)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pylint/ChangeLog7
-rw-r--r--dev-python/pylint/files/digest-pylint-0.12.13
-rw-r--r--dev-python/pylint/pylint-0.12.1.ebuild61
3 files changed, 70 insertions, 1 deletions
diff --git a/dev-python/pylint/ChangeLog b/dev-python/pylint/ChangeLog
index e982fb7ffe6c..2ad271a09441 100644
--- a/dev-python/pylint/ChangeLog
+++ b/dev-python/pylint/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pylint
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.29 2006/06/11 02:57:49 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/ChangeLog,v 1.30 2006/09/27 00:08:04 marienz Exp $
+
+*pylint-0.12.1 (27 Sep 2006)
+
+ 27 Sep 2006; Marien Zwart <marienz@gentoo.org> +pylint-0.12.1.ebuild:
+ Version bump for bug #148865 and #148422.
11 Jun 2006; Marius Mauch <genone@gentoo.org> pylint-0.9.0.ebuild,
pylint-0.11.0.ebuild:
diff --git a/dev-python/pylint/files/digest-pylint-0.12.1 b/dev-python/pylint/files/digest-pylint-0.12.1
new file mode 100644
index 000000000000..e89817295496
--- /dev/null
+++ b/dev-python/pylint/files/digest-pylint-0.12.1
@@ -0,0 +1,3 @@
+MD5 e9d04e7693fbd8dbfe7b06669c4b5b82 pylint-0.12.1.tar.gz 169263
+RMD160 5ca51bb179dd1f055359e432f1031f352dc8cfcd pylint-0.12.1.tar.gz 169263
+SHA256 57d5867e086cc98f867bc0081346f7c92e87e5ebd33f8ff148be2a463e92d738 pylint-0.12.1.tar.gz 169263
diff --git a/dev-python/pylint/pylint-0.12.1.ebuild b/dev-python/pylint/pylint-0.12.1.ebuild
new file mode 100644
index 000000000000..234cc781db58
--- /dev/null
+++ b/dev-python/pylint/pylint-0.12.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylint/pylint-0.12.1.ebuild,v 1.1 2006/09/27 00:08:04 marienz Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="PyLint is a tool to check if a Pyhon module satisfies a coding standard"
+SRC_URI="ftp://ftp.logilab.org/pub/pylint/${P}.tar.gz"
+HOMEPAGE="http://www.logilab.org/projects/pylint/"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+LICENSE="GPL-2"
+DEPEND="|| ( >=dev-python/optik-1.4 >=dev-lang/python-2.3 )
+ >=dev-python/logilab-common-0.13.0
+ >=dev-python/astng-0.16.0"
+
+DOCS="doc/*.txt"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Make the test that tries to import gtk a bit less strict
+ epatch "${FILESDIR}/${PN}-0.10.0-extra-gtk-disable.patch"
+
+ # Make pylint-gui print a gentoo-specific message if Tkinter is missing
+ epatch "${FILESDIR}/${PN}-0.11.0-gui-no-tkinter.patch"
+}
+
+src_install() {
+ distutils_src_install
+ # do not install the test suite (we ran it from src_test already
+ # and it makes .py[co] generation very noisy because there are
+ # files with SyntaxErrors in there)
+ python_version
+ rm -rf "${D}"/usr/lib*/python${PYVER}/site-packages/pylint/test
+
+ doman man/pylint.1
+ dohtml doc/*.html
+}
+
+src_test() {
+ # The tests will not work properly from the source dir, so do a
+ # temporary install:
+ "${python}" setup.py install --home="${T}/test" || die "test copy failed"
+ # dir needs to be this or the tests fail
+ cd "${T}/test/lib/python/pylint/test"
+ PYTHONPATH="${T}/test/lib/python" "${python}" runtests.py || \
+ die "tests failed"
+ cd "${S}"
+ rm -rf "${T}/test"
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ einfo 'A couple of important configuration settings (like "disable-msg")'
+ einfo 'moved from the "MASTER" to "MESSAGES CONTROL" section.'
+ einfo 'See "pylint --help".'
+}