summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-01 23:31:41 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-01 23:31:41 +0000
commitc5700c43d7c4485114eb3dbfa988d750b1fe19df (patch)
tree0c1308c10499a6095f1335687400e2a9e84900e3 /dev-python
parentRemoved the cracklib USE flag, as requested in bug 261689. (diff)
downloadgentoo-2-c5700c43d7c4485114eb3dbfa988d750b1fe19df.tar.gz
gentoo-2-c5700c43d7c4485114eb3dbfa988d750b1fe19df.tar.bz2
gentoo-2-c5700c43d7c4485114eb3dbfa988d750b1fe19df.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: 13874-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sip/ChangeLog6
-rw-r--r--dev-python/sip/sip-4.8.2.ebuild56
2 files changed, 42 insertions, 20 deletions
diff --git a/dev-python/sip/ChangeLog b/dev-python/sip/ChangeLog
index 327d22909585..fa80d9280ddc 100644
--- a/dev-python/sip/ChangeLog
+++ b/dev-python/sip/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/sip
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.136 2009/07/31 11:13:02 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.137 2009/08/01 23:31:41 arfrever Exp $
+
+ 01 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ sip-4.8.2.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
31 Jul 2009; Markos Chandras <hwoarang@gentoo.org> -sip-4.2.1.ebuild,
-sip-4.2.1-r1.ebuild, -sip-4.6.ebuild, -sip-4.7.1.ebuild,
diff --git a/dev-python/sip/sip-4.8.2.ebuild b/dev-python/sip/sip-4.8.2.ebuild
index 32882d102286..c160aae8f5b5 100644
--- a/dev-python/sip/sip-4.8.2.ebuild
+++ b/dev-python/sip/sip-4.8.2.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.8.2.ebuild,v 1.1 2009/07/31 07:06:31 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.8.2.ebuild,v 1.2 2009/08/01 23:31:41 arfrever Exp $
EAPI="2"
NEED_PYTHON="2.3"
+SUPPORT_PYTHON_ABIS="1"
inherit python toolchain-funcs
@@ -23,26 +24,44 @@ S="${WORKDIR}/${MY_P}"
DEPEND=""
RDEPEND=""
+src_prepare() {
+ python_copy_sources
+}
+
src_configure() {
- python_version
-
- local myconf="${python} configure.py
- --bindir=/usr/bin
- --destdir=$(python_get_sitedir)
- --incdir=/usr/include/python${PYVER}
- --sipdir=/usr/share/sip
- $(use debug && echo '--debug')
- CC=$(tc-getCC) CXX=$(tc-getCXX)
- LINK=$(tc-getCXX) LINK_SHLIB=$(tc-getCXX)
- CFLAGS='${CFLAGS}' CXXFLAGS='${CXXFLAGS}'
- LFLAGS='${LDFLAGS}'
- STRIP=true"
- echo ${myconf}
- eval ${myconf} || die "configuration failed"
+ configure_package() {
+ local myconf="$(get_python) configure.py
+ --bindir=/usr/bin
+ --destdir=$(python_get_sitedir)
+ --incdir=$(python_get_includedir)
+ --sipdir=/usr/share/sip
+ $(use debug && echo '--debug')
+ CC=$(tc-getCC) CXX=$(tc-getCXX)
+ LINK=$(tc-getCXX) LINK_SHLIB=$(tc-getCXX)
+ CFLAGS='${CFLAGS}' CXXFLAGS='${CXXFLAGS}'
+ LFLAGS='${LDFLAGS}'
+ STRIP=true"
+ echo ${myconf}
+ eval ${myconf}
+ }
+ python_execute_function -s configure_package
+}
+
+src_compile() {
+ build_package() {
+ emake
+ }
+ python_execute_function -s build_package
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ python_need_rebuild
+
+ install_package() {
+ emake DESTDIR="${D}" install
+ }
+ python_execute_function -s install_package
+
dodoc ChangeLog NEWS || die
if use doc; then
@@ -51,8 +70,7 @@ src_install() {
}
pkg_postinst() {
- python_need_rebuild
- python_mod_optimize "$(python_get_sitedir)"/sip*.py
+ python_mod_optimize sipconfig.py sipdistutils.py
}
pkg_postrm() {