summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-02-10 09:02:37 +0000
committerIan Delaney <idella4@gentoo.org>2013-02-10 09:02:37 +0000
commitd85ba6a477a6694e28cd89de46885ae1596ae730 (patch)
treedf22d5572afeebc68d426e8c76b1ef0a7c75ab53 /dev-python
parentMask packages for cleaning (diff)
downloadgentoo-2-d85ba6a477a6694e28cd89de46885ae1596ae730.tar.gz
gentoo-2-d85ba6a477a6694e28cd89de46885ae1596ae730.tar.bz2
gentoo-2-d85ba6a477a6694e28cd89de46885ae1596ae730.zip
bump
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/restkit/ChangeLog7
-rw-r--r--dev-python/restkit/restkit-4.2.1.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/dev-python/restkit/ChangeLog b/dev-python/restkit/ChangeLog
index 6b9d68e503bd..710a38a51078 100644
--- a/dev-python/restkit/ChangeLog
+++ b/dev-python/restkit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/restkit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/restkit/ChangeLog,v 1.8 2013/01/15 14:07:23 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/restkit/ChangeLog,v 1.9 2013/02/10 09:02:37 idella4 Exp $
+
+*restkit-4.2.1 (10 Feb 2013)
+
+ 10 Feb 2013; Ian Delaney <idella4@gentoo.org> +restkit-4.2.1.ebuild:
+ bump
15 Jan 2013; Ian Delaney <idella4@gentoo.org> restkit-4.2.0.ebuild:
tests folder removed to avoid file collisions, fixes Bug #451968
diff --git a/dev-python/restkit/restkit-4.2.1.ebuild b/dev-python/restkit/restkit-4.2.1.ebuild
new file mode 100644
index 000000000000..0ffff73fbf19
--- /dev/null
+++ b/dev-python/restkit/restkit-4.2.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/restkit/restkit-4.2.1.ebuild,v 1.1 2013/02/10 09:02:37 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="A HTTP ressource kit for Python."
+HOMEPAGE="http://github.com/benoitc/restkit http://benoitc.github.com/restkit/ http://pypi.python.org/pypi/restkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+cli doc examples test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx
+ dev-python/epydoc )
+ test? ( dev-python/webob
+ >=dev-python/socketpool-0.5.0
+ >=dev-python/http-parser-0.7.7 )"
+RDEPEND="cli? ( dev-python/ipython
+ dev-python/setuptools[${PYTHON_USEDEP}] )
+ dev-python/webob
+ >=dev-python/socketpool-0.5.0
+ >=dev-python/http-parser-0.7.7"
+
+src_compile() {
+ distutils-r1_src_compile
+
+ if use doc ; then
+ pushd doc > /dev/null
+ PYTHONPATH="${S}" emake html
+ popd > /dev/null
+ fi
+}
+
+python_test() {
+ nosetests -v tests || die
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ use cli || rm "${D}"/usr/bin/restcli*
+
+ use doc && dohtml -r doc/_build/html/
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+
+ einfo "Remove tests to avoid file collisions"
+ rm -rf $(find "${D}" -name tests) || die
+}