summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2014-12-12 14:30:05 +0000
committerMichael Palimaka <kensington@gentoo.org>2014-12-12 14:30:05 +0000
commit3a699f48ee514c68f307e566e688a38ffb5800e5 (patch)
tree2fada309e481b43a0c04b1edaf142d4ae9154ae6 /dev-qt/qtquickcontrols/qtquickcontrols-5.4.0.ebuild
parentDowngrade overzealous ffmpeg version dependency (diff)
downloadgentoo-2-3a699f48ee514c68f307e566e688a38ffb5800e5.tar.gz
gentoo-2-3a699f48ee514c68f307e566e688a38ffb5800e5.tar.bz2
gentoo-2-3a699f48ee514c68f307e566e688a38ffb5800e5.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
Diffstat (limited to 'dev-qt/qtquickcontrols/qtquickcontrols-5.4.0.ebuild')
-rw-r--r--dev-qt/qtquickcontrols/qtquickcontrols-5.4.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-qt/qtquickcontrols/qtquickcontrols-5.4.0.ebuild b/dev-qt/qtquickcontrols/qtquickcontrols-5.4.0.ebuild
new file mode 100644
index 000000000000..608cb0c1f7b7
--- /dev/null
+++ b/dev-qt/qtquickcontrols/qtquickcontrols-5.4.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-qt/qtquickcontrols/qtquickcontrols-5.4.0.ebuild,v 1.1 2014/12/12 14:30:04 kensington Exp $
+
+EAPI=5
+
+inherit qt5-build
+
+DESCRIPTION="Set of controls used in conjunction with Qt Quick to build complete interfaces"
+
+if [[ ${QT5_BUILD_TYPE} == live ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+fi
+
+IUSE="widgets"
+
+DEPEND="
+ >=dev-qt/qtcore-${PV}:5[debug=]
+ >=dev-qt/qtdeclarative-${PV}:5[debug=]
+ >=dev-qt/qtgui-${PV}:5[debug=]
+ widgets? ( >=dev-qt/qtwidgets-${PV}:5[debug=] )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ qt_use_disable_mod widgets widgets \
+ src/src.pro \
+ src/controls/Private/private.pri \
+ tests/auto/activeFocusOnTab/activeFocusOnTab.pro \
+ tests/auto/controls/controls.pro \
+ tests/auto/testplugin/testplugin.pro
+
+ qt5-build_src_prepare
+}