summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-05-06 19:29:54 +0000
committerHans de Graaff <graaff@gentoo.org>2014-05-06 19:29:54 +0000
commit04c25df676f5023956c7cae3d9012c9ecdc01e4b (patch)
tree5afe4b22b08c4f5c1288f57e0eb9ad59fa3b452b /dev-ruby/actionmailer
parentVersion bump for Rails 4.0.5, security bug 509706. (diff)
downloadgentoo-2-04c25df676f5023956c7cae3d9012c9ecdc01e4b.tar.gz
gentoo-2-04c25df676f5023956c7cae3d9012c9ecdc01e4b.tar.bz2
gentoo-2-04c25df676f5023956c7cae3d9012c9ecdc01e4b.zip
Version bump for Rails 4.0.5, security bug 509706.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/actionmailer')
-rw-r--r--dev-ruby/actionmailer/ChangeLog7
-rw-r--r--dev-ruby/actionmailer/actionmailer-4.0.5.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index 4b380c7ce220..4fe98c3ce772 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.258 2014/05/06 18:52:09 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.259 2014/05/06 19:29:54 graaff Exp $
+
+*actionmailer-4.0.5 (06 May 2014)
+
+ 06 May 2014; Hans de Graaff <graaff@gentoo.org> +actionmailer-4.0.5.ebuild:
+ Version bump for Rails 4.0.5, security bug 509706.
*actionmailer-3.2.18 (06 May 2014)
diff --git a/dev-ruby/actionmailer/actionmailer-4.0.5.ebuild b/dev-ruby/actionmailer/actionmailer-4.0.5.ebuild
new file mode 100644
index 000000000000..dc83345c9510
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-4.0.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-4.0.5.ebuild,v 1.1 2014/05/06 19:29:54 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/mail-2.5.4:2.5"
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ dev-ruby/mocha:0.13
+)"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|redcarpet\)/d" ../Gemfile || die
+ sed -i -e '/rack-ssl/d' -e 's/~> 3.4/>= 3.4/' ../railties/railties.gemspec || die
+}