summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-08-11 08:37:36 +0000
committerHans de Graaff <graaff@gentoo.org>2012-08-11 08:37:36 +0000
commitccebf6605a22595e5b91122fcce562c634062081 (patch)
treedc0663dad49b4274d8066e08a3da9ec790300f40 /dev-ruby/actionmailer
parentVersion bumps for security bug 430718. (diff)
downloadgentoo-2-ccebf6605a22595e5b91122fcce562c634062081.tar.gz
gentoo-2-ccebf6605a22595e5b91122fcce562c634062081.tar.bz2
gentoo-2-ccebf6605a22595e5b91122fcce562c634062081.zip
Version bumps for security bug 430718.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/actionmailer')
-rw-r--r--dev-ruby/actionmailer/ChangeLog9
-rw-r--r--dev-ruby/actionmailer/actionmailer-3.0.17.ebuild42
-rw-r--r--dev-ruby/actionmailer/actionmailer-3.1.8.ebuild39
3 files changed, 89 insertions, 1 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index fbee78648d68..c6a5f3c26ea0 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/actionmailer
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.197 2012/08/10 06:44:07 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.198 2012/08/11 08:37:36 graaff Exp $
+
+*actionmailer-3.1.8 (11 Aug 2012)
+*actionmailer-3.0.17 (11 Aug 2012)
+
+ 11 Aug 2012; Hans de Graaff <graaff@gentoo.org> +actionmailer-3.0.17.ebuild,
+ +actionmailer-3.1.8.ebuild:
+ Version bumps for security bug 430718.
*actionmailer-3.2.8 (10 Aug 2012)
diff --git a/dev-ruby/actionmailer/actionmailer-3.0.17.ebuild b/dev-ruby/actionmailer/actionmailer-3.0.17.ebuild
new file mode 100644
index 000000000000..180235065307
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-3.0.17.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-3.0.17.ebuild,v 1.1 2012/08/11 08:37:36 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/actionmailer"
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/mail-2.2.19"
+ruby_add_bdepend "test? (
+ >=dev-ruby/mocha-0.10.5
+)"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ sed -i -e '/dependency.*mail/s:~>:>=:' "${RUBY_FAKEGEM_GEMSPEC}" || die
+
+ # Rename private method to avoid conflict with the simple_format
+ # TextHelper. Already fixed in Rails 3.1.
+ sed -i -e 's/simple_format/format_paragraph/' lib/action_mailer/mail_helper.rb || die
+}
diff --git a/dev-ruby/actionmailer/actionmailer-3.1.8.ebuild b/dev-ruby/actionmailer/actionmailer-3.1.8.ebuild
new file mode 100644
index 000000000000..bbedb92c9d7f
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-3.1.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-3.1.8.ebuild,v 1.1 2012/08/11 08:37:36 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="http://rubyforge.org/projects/actionmailer/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.1"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/actionmailer"
+
+ruby_add_rdepend "~dev-ruby/actionpack-${PV}
+ >=dev-ruby/mail-2.3.3:2.3"
+ruby_add_bdepend "test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+)"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ sed -i -e '/dependency.*mail/s:~>:>=:' "${RUBY_FAKEGEM_GEMSPEC}" || die
+}