summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-01-01 10:20:50 +0000
committerHans de Graaff <graaff@gentoo.org>2015-01-01 10:20:50 +0000
commitb4a8481e37ad643d0166f5ce8f329a299fef7ffb (patch)
tree61cbd29cdd09be8d4c545473262a27542e880ca8 /dev-ruby/actionpack
parentInitial import. New dependency for Rails 4.2. (diff)
downloadgentoo-2-b4a8481e37ad643d0166f5ce8f329a299fef7ffb.tar.gz
gentoo-2-b4a8481e37ad643d0166f5ce8f329a299fef7ffb.tar.bz2
gentoo-2-b4a8481e37ad643d0166f5ce8f329a299fef7ffb.zip
Version bump for Rails 4.2. Dropped keywords tracked in bug 534186.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/actionpack')
-rw-r--r--dev-ruby/actionpack/ChangeLog9
-rw-r--r--dev-ruby/actionpack/actionpack-4.2.0.ebuild50
2 files changed, 57 insertions, 2 deletions
diff --git a/dev-ruby/actionpack/ChangeLog b/dev-ruby/actionpack/ChangeLog
index 0d5216ccf0c2..6a186e87b186 100644
--- a/dev-ruby/actionpack/ChangeLog
+++ b/dev-ruby/actionpack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionpack
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.297 2014/12/20 07:30:36 graaff Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.298 2015/01/01 10:20:50 graaff Exp $
+
+*actionpack-4.2.0 (01 Jan 2015)
+
+ 01 Jan 2015; Hans de Graaff <graaff@gentoo.org> +actionpack-4.2.0.ebuild:
+ Version bump for Rails 4.2. Dropped keywords tracked in bug 534186.
20 Dec 2014; Hans de Graaff <graaff@gentoo.org> -actionpack-3.2.20.ebuild,
-actionpack-4.0.11.ebuild, -actionpack-4.1.7.ebuild:
diff --git a/dev-ruby/actionpack/actionpack-4.2.0.ebuild b/dev-ruby/actionpack/actionpack-4.2.0.ebuild
new file mode 100644
index 000000000000..28d7c4f82795
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-4.2.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-4.2.0.ebuild,v 1.1 2015/01/01 10:20:50 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionpack.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Eases web-request routing, handling, and response"
+HOMEPAGE="http://rubyforge.org/projects/actionpack/"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ ~dev-ruby/actionview-${PV}
+ >=dev-ruby/rack-1.6.0:1.6
+ >=dev-ruby/rack-test-0.6.2:0.6
+ >=dev-ruby/rails-html-sanitizer-1.0.1:1
+ >=dev-ruby/rails-dom-testing-1.0.5:1
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha:0.14
+ dev-ruby/bundler
+ ~dev-ruby/activemodel-${PV}
+ >=dev-ruby/rack-cache-1.2:1.2
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|minitest\)/ s:^:#:" \
+ -e '/:job/,/end/ s:^:#:' ../Gemfile || die
+}