summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-07-16 05:32:44 +0000
committerHans de Graaff <graaff@gentoo.org>2013-07-16 05:32:44 +0000
commit8f91aa6e52458345e8105858191c9782f28a7487 (patch)
treea04604f44fa9dd38b0cf87f4af6aebd972b9af94 /dev-ruby/facter
parentFixing qtgui deps for qt-4.8.5 (diff)
downloadgentoo-2-8f91aa6e52458345e8105858191c9782f28a7487.tar.gz
gentoo-2-8f91aa6e52458345e8105858191c9782f28a7487.tar.bz2
gentoo-2-8f91aa6e52458345e8105858191c9782f28a7487.zip
Version bump. Provide the custom facts directory in /etc/facter/facts.d
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/facter')
-rw-r--r--dev-ruby/facter/ChangeLog7
-rw-r--r--dev-ruby/facter/facter-1.7.2.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-ruby/facter/ChangeLog b/dev-ruby/facter/ChangeLog
index eef4fe4944e7..69afaf4358d7 100644
--- a/dev-ruby/facter/ChangeLog
+++ b/dev-ruby/facter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/facter
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/facter/ChangeLog,v 1.76 2013/07/16 05:20:50 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/facter/ChangeLog,v 1.77 2013/07/16 05:32:44 graaff Exp $
+
+*facter-1.7.2 (16 Jul 2013)
+
+ 16 Jul 2013; Hans de Graaff <graaff@gentoo.org> +facter-1.7.2.ebuild:
+ Version bump. Provide the custom facts directory in /etc/facter/facts.d
16 Jul 2013; Hans de Graaff <graaff@gentoo.org> -facter-1.6.0.ebuild,
-facter-1.7.0.ebuild, -facter-1.7.1.ebuild:
diff --git a/dev-ruby/facter/facter-1.7.2.ebuild b/dev-ruby/facter/facter-1.7.2.ebuild
new file mode 100644
index 000000000000..6c6e5ee16c87
--- /dev/null
+++ b/dev-ruby/facter/facter-1.7.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/facter/facter-1.7.2.ebuild,v 1.1 2013/07/16 05:32:44 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 jruby"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_BINWRAP="facter"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A cross-platform Ruby library for retrieving facts from operating systems"
+HOMEPAGE="http://www.puppetlabs.com/puppet/related-projects/facter/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+dmi +pciutils"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+CDEPEND="
+ sys-apps/net-tools
+ sys-apps/lsb-release
+ dmi? ( sys-apps/dmidecode )
+ pciutils? ( sys-apps/pciutils )"
+
+RDEPEND+=" ${CDEPEND}"
+DEPEND+=" test? ( ${CDEPEND} )"
+
+#RUBY_PATCHES=( ${P}-fix-proc-self-status.patch )
+
+ruby_add_bdepend "test? ( >=dev-ruby/mocha-0.10.5:0.10 )"
+
+all_ruby_prepare() {
+ # Provide explicit path since /sbin is not in the default PATH on
+ # Gentoo.
+ sed -i -e 's:arp -an:/sbin/arp -an:' lib/facter/util/ec2.rb spec/unit/util/ec2_spec.rb || die
+
+ # Ensure the correct version of mocha is used without using bundler.
+ sed -i -e '9igem "mocha", "~>0.10.5"' spec/spec_helper.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ # Create the directory for custom facts.
+ keepdir /etc/facter/facts.d
+}