summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2007-11-18 18:59:09 +0000
committerMatti Bickel <mabi@gentoo.org>2007-11-18 18:59:09 +0000
commitbfd3a951b8f2e1a52f9c718bc781333ab12fb706 (patch)
tree885726cb8616352d618be5817768829c653e2f8c /dev-ruby/fxruby/fxruby-1.4.7-r1.ebuild
parentadd a notice about other plugins (diff)
downloadgentoo-2-bfd3a951b8f2e1a52f9c718bc781333ab12fb706.tar.gz
gentoo-2-bfd3a951b8f2e1a52f9c718bc781333ab12fb706.tar.bz2
gentoo-2-bfd3a951b8f2e1a52f9c718bc781333ab12fb706.zip
Fixed 1.4 to link against fox-1.4 fxscintilla, Version bump for 1.6
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-ruby/fxruby/fxruby-1.4.7-r1.ebuild')
-rw-r--r--dev-ruby/fxruby/fxruby-1.4.7-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/fxruby/fxruby-1.4.7-r1.ebuild b/dev-ruby/fxruby/fxruby-1.4.7-r1.ebuild
new file mode 100644
index 000000000000..c6d1320f379f
--- /dev/null
+++ b/dev-ruby/fxruby/fxruby-1.4.7-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/fxruby-1.4.7-r1.ebuild,v 1.1 2007/11/18 18:59:08 mabi Exp $
+
+RUBY_BUG_145222=yes
+inherit ruby
+
+MY_P="FXRuby-${PV}"
+
+DESCRIPTION="Ruby language binding to the FOX GUI toolkit"
+HOMEPAGE="http://www.fxruby.org/"
+SRC_URI="http://rubyforge.org/frs/download.php/13144/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="1.4"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="examples doc"
+
+DEPEND="=x11-libs/fox-1.4*
+ >=x11-libs/fxscintilla-1.62-r1"
+USE_RUBY="ruby16 ruby18 ruby19"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e 's:libs, "fxscintilla":libs, "fxscintilla-1.4":g' \
+ ext/fox14/extconf.rb || die "sed error"
+ einfo "Avoid -O0 builds"
+ sed -i -e 's:-O0 -Iinclude:-Iinclude:g' \
+ ext/fox14/extconf.rb || die "Can't fix forced -O0"
+}