summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-11-16 06:47:02 +0000
committerHans de Graaff <graaff@gentoo.org>2012-11-16 06:47:02 +0000
commitabb9803b9378a0dd881eedf4d5fe064ecdab2a7e (patch)
treeb953cdef96373beb7bc8373cf61b1098e9ae3dba /dev-ruby/gherkin
parentVersion bump. (diff)
downloadgentoo-2-abb9803b9378a0dd881eedf4d5fe064ecdab2a7e.tar.gz
gentoo-2-abb9803b9378a0dd881eedf4d5fe064ecdab2a7e.tar.bz2
gentoo-2-abb9803b9378a0dd881eedf4d5fe064ecdab2a7e.zip
Remove experimental slotted gherkin packages.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/gherkin')
-rw-r--r--dev-ruby/gherkin/ChangeLog6
-rw-r--r--dev-ruby/gherkin/gherkin-2.10.0.ebuild71
-rw-r--r--dev-ruby/gherkin/gherkin-2.9.3.ebuild72
3 files changed, 5 insertions, 144 deletions
diff --git a/dev-ruby/gherkin/ChangeLog b/dev-ruby/gherkin/ChangeLog
index 97cdbf071c65..18261e2c65da 100644
--- a/dev-ruby/gherkin/ChangeLog
+++ b/dev-ruby/gherkin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/gherkin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/ChangeLog,v 1.44 2012/11/16 06:45:56 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/ChangeLog,v 1.45 2012/11/16 06:47:02 graaff Exp $
+
+ 16 Nov 2012; Hans de Graaff <graaff@gentoo.org> -gherkin-2.9.3.ebuild,
+ -gherkin-2.10.0.ebuild:
+ Remove experimental slotted gherkin packages.
*gherkin-2.11.5 (16 Nov 2012)
diff --git a/dev-ruby/gherkin/gherkin-2.10.0.ebuild b/dev-ruby/gherkin/gherkin-2.10.0.ebuild
deleted file mode 100644
index fb4d3d5899df..000000000000
--- a/dev-ruby/gherkin/gherkin-2.10.0.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/gherkin-2.10.0.ebuild,v 1.1 2012/05/12 09:29:29 graaff Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ruby19 ree18"
-
-RUBY_FAKEGEM_TASK_DOC="yard"
-RUBY_FAKEGEM_TASK_TEST=""
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="History.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Fast Gherkin lexer and parser based on Ragel."
-HOMEPAGE="http://wiki.github.com/aslakhellesoy/cucumber/gherkin"
-LICENSE="MIT"
-SRC_URI="https://github.com/cucumber/gherkin/tarball/v${PV} -> ${P}.tgz"
-
-KEYWORDS="~amd64"
-SLOT="2.10"
-IUSE="doc test"
-
-DEPEND="${DEPEND} dev-util/ragel"
-RDEPEND="${RDEPEND}"
-
-RUBY_S="cucumber-gherkin-*"
-
-ruby_add_bdepend "
- dev-ruby/rake-compiler
- test? (
- >=dev-ruby/builder-2.1.2
- >=dev-util/cucumber-1.1.3
- >=dev-ruby/rspec-2.6.0
- >=dev-ruby/term-ansicolor-1.0.5
- )
- doc? ( >=dev-ruby/yard-0.7.4 )"
-
-ruby_add_rdepend ">=dev-ruby/json-1.4.6"
-
-all_ruby_prepare() {
- # Remove Bundler-related things.
- sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb features/support/env.rb || die
- rm Gemfile || die
-
- # Don't use compile dependencies to avoid building again for specs.
- sed -i -e '/:compile/d' Rakefile
-
- # Remove feature that depends on direct access to the cucumber
- # source. We could probably set this up by downloading the source
- # and unpacking it, but skipping this now in the interest of time.
- rm features/pretty_formatter.feature || die
-
- # We need to remove these tasks during bootstrapping since it tries
- # to load cucumber already but we can be sure it isn't installed
- # yet. Also remove other rake tasks for which we may not yet have
- # dependencies.
- if ! use test ; then
- rm tasks/cucumber.rake tasks/rspec.rake || die "Unable to remove rake tasks."
- fi
-}
-
-each_ruby_compile() {
- ${RUBY} -I lib -S rake -rrake/clean -f tasks/compile.rake compile || die
-}
-
-each_ruby_test() {
- ${RUBY} -I lib -S rake spec || die "Specs failed"
- CUCUMBER_HOME="${HOME}" RUBYLIB=lib ${RUBY} -S cucumber features || die "Cucumber features failed"
-}
diff --git a/dev-ruby/gherkin/gherkin-2.9.3.ebuild b/dev-ruby/gherkin/gherkin-2.9.3.ebuild
deleted file mode 100644
index 59cdddf6bdb6..000000000000
--- a/dev-ruby/gherkin/gherkin-2.9.3.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/gherkin-2.9.3.ebuild,v 1.1 2012/04/27 07:41:35 graaff Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ruby19 ree18"
-
-RUBY_FAKEGEM_TASK_DOC="yard"
-RUBY_FAKEGEM_TASK_TEST=""
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="History.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Fast Gherkin lexer and parser based on Ragel."
-HOMEPAGE="http://wiki.github.com/aslakhellesoy/cucumber/gherkin"
-LICENSE="MIT"
-SRC_URI="https://github.com/cucumber/gherkin/tarball/v${PV} -> ${P}.tgz"
-
-KEYWORDS="~amd64"
-SLOT="2.9"
-IUSE="doc test"
-
-DEPEND="${DEPEND} dev-util/ragel"
-RDEPEND="${RDEPEND}"
-
-RUBY_S="cucumber-gherkin-*"
-
-ruby_add_bdepend "
- dev-ruby/rake-compiler
- test? (
- >=dev-ruby/awesome_print-0.4.0
- >=dev-ruby/builder-2.1.2
- >=dev-util/cucumber-1.1.3
- >=dev-ruby/rspec-2.6.0
- >=dev-ruby/term-ansicolor-1.0.5
- )
- doc? ( >=dev-ruby/yard-0.7.4 )"
-
-ruby_add_rdepend ">=dev-ruby/json-1.4.6"
-
-all_ruby_prepare() {
- # Remove Bundler-related things.
- sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb features/support/env.rb || die
- rm Gemfile || die
-
- # Don't use compile dependencies to avoid building again for specs.
- sed -i -e '/:compile/d' Rakefile
-
- # Remove feature that depends on direct access to the cucumber
- # source. We could probably set this up by downloading the source
- # and unpacking it, but skipping this now in the interest of time.
- rm features/pretty_formatter.feature || die
-
- # We need to remove these tasks during bootstrapping since it tries
- # to load cucumber already but we can be sure it isn't installed
- # yet. Also remove other rake tasks for which we may not yet have
- # dependencies.
- if ! use test ; then
- rm tasks/cucumber.rake tasks/rspec.rake || die "Unable to remove rake tasks."
- fi
-}
-
-each_ruby_compile() {
- ${RUBY} -I lib -S rake -rrake/clean -f tasks/compile.rake compile || die
-}
-
-each_ruby_test() {
- ${RUBY} -I lib -S rake spec || die "Specs failed"
- CUCUMBER_HOME="${HOME}" RUBYLIB=lib ${RUBY} -S cucumber features || die "Cucumber features failed"
-}