summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-04 04:03:52 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-04 04:03:52 +0000
commitc385b126dcfd6815245f71e5b3ff21a16420cea1 (patch)
treed8a6321edc11ff9e4071f23e0548c75207f1faa6 /dev-ruby/httpclient
parentDrop qt3 support, bug 283429 (diff)
downloadgentoo-2-c385b126dcfd6815245f71e5b3ff21a16420cea1.tar.gz
gentoo-2-c385b126dcfd6815245f71e5b3ff21a16420cea1.tar.bz2
gentoo-2-c385b126dcfd6815245f71e5b3ff21a16420cea1.zip
Bump to ruby-fakegem; jruby support requires jruby-openssl. Tests are known to fail right now.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/httpclient')
-rw-r--r--dev-ruby/httpclient/ChangeLog11
-rw-r--r--dev-ruby/httpclient/httpclient-2.1.5.2-r1.ebuild36
2 files changed, 45 insertions, 2 deletions
diff --git a/dev-ruby/httpclient/ChangeLog b/dev-ruby/httpclient/ChangeLog
index 1e90d456a2df..f551f7729129 100644
--- a/dev-ruby/httpclient/ChangeLog
+++ b/dev-ruby/httpclient/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/httpclient
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/ChangeLog,v 1.9 2009/08/23 07:47:49 graaff Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/ChangeLog,v 1.10 2010/01/04 04:03:52 flameeyes Exp $
+
+*httpclient-2.1.5.2-r1 (04 Jan 2010)
+
+ 04 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +httpclient-2.1.5.2-r1.ebuild:
+ Bump to ruby-fakegem; jruby support requires jruby-openssl. Tests are
+ known to fail right now.
*httpclient-2.1.5.2 (23 Aug 2009)
diff --git a/dev-ruby/httpclient/httpclient-2.1.5.2-r1.ebuild b/dev-ruby/httpclient/httpclient-2.1.5.2-r1.ebuild
new file mode 100644
index 000000000000..426632f4ad03
--- /dev/null
+++ b/dev-ruby/httpclient/httpclient-2.1.5.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/httpclient-2.1.5.2-r1.ebuild,v 1.1 2010/01/04 04:03:52 flameeyes Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="-Ilib test"
+RUBY_FAKEGEM_TASK_DOC="-Ilib doc"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="'httpclient' gives something like the functionality of libwww-perl (LWP) in Ruby"
+HOMEPAGE="http://dev.ctor.org/http-access2/"
+SRC_URI="http://dev.ctor.org/download/${P}.tar.gz"
+
+LICENSE="Ruby"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="!dev-ruby/http-access2"
+
+# tests are known to fail, but at least they fail for all
+# implementations in the same way.
+ruby_add_bdepend test virtual/ruby-test-unit
+
+# JRuby-specific dependency
+USE_RUBY="jruby" \
+ ruby_add_rdepend ruby_targets_jruby dev-ruby/jruby-openssl