summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-13 13:10:19 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-13 13:10:19 +0000
commit421857ce1484f0ac3ed89ebcf48fa90203628569 (patch)
tree5af0b2b2ee872afc1ccc9652476084976103c294 /dev-ruby/mini_magick
parentInstall missing words file wrt #300792, thanks to Johannes Rauh for reporting. (diff)
downloadgentoo-2-421857ce1484f0ac3ed89ebcf48fa90203628569.tar.gz
gentoo-2-421857ce1484f0ac3ed89ebcf48fa90203628569.tar.bz2
gentoo-2-421857ce1484f0ac3ed89ebcf48fa90203628569.zip
Initial import of mini_magick, needed by Typo master. Tests currently fail (at least with ImageMagick 6.5.8.8), and the two changes are sent upstream for merging.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/mini_magick')
-rw-r--r--dev-ruby/mini_magick/ChangeLog13
-rw-r--r--dev-ruby/mini_magick/files/mini_magick-1.2.5-tests-tempdir.patch14
-rw-r--r--dev-ruby/mini_magick/metadata.xml5
-rw-r--r--dev-ruby/mini_magick/mini_magick-1.2.5.ebuild39
4 files changed, 71 insertions, 0 deletions
diff --git a/dev-ruby/mini_magick/ChangeLog b/dev-ruby/mini_magick/ChangeLog
new file mode 100644
index 000000000000..e0ba9c6f0f19
--- /dev/null
+++ b/dev-ruby/mini_magick/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for dev-ruby/mini_magick
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mini_magick/ChangeLog,v 1.1 2010/01/13 13:10:18 flameeyes Exp $
+
+*mini_magick-1.2.5 (13 Jan 2010)
+
+ 13 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +mini_magick-1.2.5.ebuild, +files/mini_magick-1.2.5-tests-tempdir.patch,
+ +metadata.xml:
+ Initial import of mini_magick, needed by Typo master. Tests currently fail
+ (at least with ImageMagick 6.5.8.8), and the two changes are sent upstream
+ for merging.
+
diff --git a/dev-ruby/mini_magick/files/mini_magick-1.2.5-tests-tempdir.patch b/dev-ruby/mini_magick/files/mini_magick-1.2.5-tests-tempdir.patch
new file mode 100644
index 000000000000..99f01f8a2eaf
--- /dev/null
+++ b/dev-ruby/mini_magick/files/mini_magick-1.2.5-tests-tempdir.patch
@@ -0,0 +1,14 @@
+diff --git a/test/image_temp_file_test.rb b/test/image_temp_file_test.rb
+index bf6a368..7478688 100644
+--- a/test/image_temp_file_test.rb
++++ b/test/image_temp_file_test.rb
+@@ -11,7 +11,7 @@ class ImageTempFileTest < Test::Unit::TestCase
+ end
+
+ def test_temp_file_has_given_extension
+- assert_match /^[^.]+\.jpg$/, ImageTempFile.new('jpg').path
+- assert_match /^[^.]+\.png$/, ImageTempFile.new('png').path
++ assert_match /^.+\.jpg$/, ImageTempFile.new('jpg').path
++ assert_match /^.+\.png$/, ImageTempFile.new('png').path
+ end
+ end
diff --git a/dev-ruby/mini_magick/metadata.xml b/dev-ruby/mini_magick/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/mini_magick/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/mini_magick/mini_magick-1.2.5.ebuild b/dev-ruby/mini_magick/mini_magick-1.2.5.ebuild
new file mode 100644
index 000000000000..2da324a389f3
--- /dev/null
+++ b/dev-ruby/mini_magick/mini_magick-1.2.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mini_magick/mini_magick-1.2.5.ebuild,v 1.1 2010/01/13 13:10:18 flameeyes Exp $
+
+EAPI=2
+
+# jruby → test_tempfile_at_path_after_format fails with jruby 1.3.1,
+# sounds like a bug in JRuby itself, or the code not being compatible.
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Manipulate images with minimal use of memory."
+HOMEPAGE="http://github.com/probablycorey/mini_magick"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# It's only used at runtime in this case because this extension only
+# _calls_ the commands. But when we run tests we're going to need tiff
+# and jpeg support at a minimum.
+RDEPEND="media-gfx/imagemagick"
+DEPEND="test? ( media-gfx/imagemagick[tiff,jpeg] )"
+
+# tests are known to fail under imagemagick 6.5 at least, reported upstream:
+# http://github.com/probablycorey/mini_magick/issues/#issue/2
+ruby_add_bdepend test virtual/ruby-test-unit
+
+all_ruby_prepare() {
+ # remove executable bit from all files
+ find "${S}" -type f -exec chmod -x {} +
+
+ epatch "${FILESDIR}"/${P}-tests-tempdir.patch
+}