summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-10-02 12:22:11 +0000
committerHans de Graaff <graaff@gentoo.org>2010-10-02 12:22:11 +0000
commit4f03784b658fdc1b1caa25f5a4fb78b43a3140c7 (patch)
tree063510a75a7b19b7c55c0c7cb71caf57f78b42d4 /dev-ruby/multi_json/multi_json-0.0.4.ebuild
parentVersion bump. Do not build tests if not needed, bug #226221. Disable broken t... (diff)
downloadgentoo-2-4f03784b658fdc1b1caa25f5a4fb78b43a3140c7.tar.gz
gentoo-2-4f03784b658fdc1b1caa25f5a4fb78b43a3140c7.tar.bz2
gentoo-2-4f03784b658fdc1b1caa25f5a4fb78b43a3140c7.zip
Remove bundler code because it requires all optional dependencies to be installed. Fix RSpec dependency.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/multi_json/multi_json-0.0.4.ebuild')
-rw-r--r--dev-ruby/multi_json/multi_json-0.0.4.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-ruby/multi_json/multi_json-0.0.4.ebuild b/dev-ruby/multi_json/multi_json-0.0.4.ebuild
index 8a31411bb468..60f87b11cd5f 100644
--- a/dev-ruby/multi_json/multi_json-0.0.4.ebuild
+++ b/dev-ruby/multi_json/multi_json-0.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/multi_json-0.0.4.ebuild,v 1.1 2010/06/19 17:33:02 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/multi_json-0.0.4.ebuild,v 1.2 2010/10/02 12:22:11 graaff Exp $
EAPI=2
@@ -27,6 +27,10 @@ ruby_add_rdepend "|| ( dev-ruby/json dev-ruby/yajl-ruby dev-ruby/activesupport )
# I've switched one of the tests from requiring yajl to requiring
# json-pure since it's the only implementation that is available for
# all the Ruby interpreters we support.
-ruby_add_bdepend "test? ( dev-ruby/rspec dev-ruby/json )"
+ruby_add_bdepend "test? ( dev-ruby/rspec:0 dev-ruby/json )"
RUBY_PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' spec/spec_helper.rb || die "Unable to remove bundler."
+}