summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2011-08-27 09:43:35 +0000
committerFabian Groffen <grobian@gentoo.org>2011-08-27 09:43:35 +0000
commitc112546f716a3da6f1ca08a00b2bff5ecaea0d44 (patch)
tree61c63bd39bbaaf8df9504517994c2b2196753cf1 /dev-ruby/nokogiri
parentStable on amd64 wrt bug #380655 (diff)
downloadgentoo-2-c112546f716a3da6f1ca08a00b2bff5ecaea0d44.tar.gz
gentoo-2-c112546f716a3da6f1ca08a00b2bff5ecaea0d44.tar.bz2
gentoo-2-c112546f716a3da6f1ca08a00b2bff5ecaea0d44.zip
Provide locations to libraries, and help extconf to guess the library name of libiconv for Prefix platforms. Marked ~x64-macos
(Portage version: 2.2.01.19074-prefix/cvs/Darwin i386)
Diffstat (limited to 'dev-ruby/nokogiri')
-rw-r--r--dev-ruby/nokogiri/ChangeLog6
-rw-r--r--dev-ruby/nokogiri/nokogiri-1.5.0.ebuild15
2 files changed, 17 insertions, 4 deletions
diff --git a/dev-ruby/nokogiri/ChangeLog b/dev-ruby/nokogiri/ChangeLog
index 87ab6e367238..56c31dfc2982 100644
--- a/dev-ruby/nokogiri/ChangeLog
+++ b/dev-ruby/nokogiri/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/nokogiri
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/ChangeLog,v 1.60 2011/08/02 16:31:57 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/ChangeLog,v 1.61 2011/08/27 09:43:35 grobian Exp $
+
+ 27 Aug 2011; Fabian Groffen <grobian@gentoo.org> nokogiri-1.5.0.ebuild:
+ Provide locations to libraries, and help extconf to guess the library name of
+ libiconv for Prefix platforms. Marked ~x64-macos
02 Aug 2011; Markos Chandras <hwoarang@gentoo.org> nokogiri-1.4.4-r1.ebuild:
Stable on amd64 wrt bug #348510
diff --git a/dev-ruby/nokogiri/nokogiri-1.5.0.ebuild b/dev-ruby/nokogiri/nokogiri-1.5.0.ebuild
index 843ed80822f5..e99a2e755cb3 100644
--- a/dev-ruby/nokogiri/nokogiri-1.5.0.ebuild
+++ b/dev-ruby/nokogiri/nokogiri-1.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/nokogiri-1.5.0.ebuild,v 1.1 2011/07/09 10:15:44 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/nokogiri-1.5.0.ebuild,v 1.2 2011/08/27 09:43:35 grobian Exp $
EAPI=2
@@ -16,7 +16,7 @@ DESCRIPTION="Nokogiri is an HTML, XML, SAX, and Reader parser."
HOMEPAGE="http://nokogiri.rubyforge.org/"
LICENSE="MIT"
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
SLOT="0"
IUSE=""
@@ -49,7 +49,16 @@ all_ruby_prepare() {
}
each_ruby_configure() {
- ${RUBY} -Cext/${PN} extconf.rb || die "extconf.rb failed"
+ ${RUBY} -Cext/${PN} extconf.rb \
+ --with-zlib-include="${EPREFIX}"/usr/include \
+ --with-zlib-lib="${EPREFIX}"/$(get_libdir) \
+ --with-iconv-include="${EPREFIX}"/usr/include \
+ --with-iconv-lib="${EPREFIX}"/$(get_libdir) \
+ --with-xml2-include="${EPREFIX}"/usr/include/libxml2 \
+ --with-xml2-lib="${EPREFIX}"/usr/$(get_libdir) \
+ --with-xslt-dir="${EPREFIX}"/usr \
+ --with-iconvlib=iconv \
+ || die "extconf.rb failed"
}
each_ruby_compile() {