summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-08-19 09:05:33 +0000
committerHans de Graaff <graaff@gentoo.org>2012-08-19 09:05:33 +0000
commit1ca3ce21b7639665d4ecb693adb98b408de011bf (patch)
tree6d6be8ab4bea6ebafaea6dcb50186499972f1771 /dev-ruby/parsetree
parentppc stable wrt bug#431902. Fix automagic fetching during build (already fixed... (diff)
downloadgentoo-2-1ca3ce21b7639665d4ecb693adb98b408de011bf.tar.gz
gentoo-2-1ca3ce21b7639665d4ecb693adb98b408de011bf.tar.bz2
gentoo-2-1ca3ce21b7639665d4ecb693adb98b408de011bf.zip
Fix RubyInline version to actually match versions in our tree.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/parsetree')
-rw-r--r--dev-ruby/parsetree/ChangeLog7
-rw-r--r--dev-ruby/parsetree/parsetree-3.0.9-r1.ebuild93
2 files changed, 99 insertions, 1 deletions
diff --git a/dev-ruby/parsetree/ChangeLog b/dev-ruby/parsetree/ChangeLog
index a538aaf50b42..9fda9b9d31b1 100644
--- a/dev-ruby/parsetree/ChangeLog
+++ b/dev-ruby/parsetree/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/parsetree
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/parsetree/ChangeLog,v 1.50 2012/08/16 03:59:53 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/parsetree/ChangeLog,v 1.51 2012/08/19 09:05:33 graaff Exp $
+
+*parsetree-3.0.9-r1 (19 Aug 2012)
+
+ 19 Aug 2012; Hans de Graaff <graaff@gentoo.org> +parsetree-3.0.9-r1.ebuild:
+ Fix RubyInline version to actually match versions in our tree.
16 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org> parsetree-3.0.6.ebuild,
parsetree-3.0.7.ebuild, parsetree-3.0.8.ebuild, parsetree-3.0.9.ebuild:
diff --git a/dev-ruby/parsetree/parsetree-3.0.9-r1.ebuild b/dev-ruby/parsetree/parsetree-3.0.9-r1.ebuild
new file mode 100644
index 000000000000..ee58f393e878
--- /dev/null
+++ b/dev-ruby/parsetree/parsetree-3.0.9-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/parsetree/parsetree-3.0.9-r1.ebuild,v 1.1 2012/08/19 09:05:33 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_NAME="ParseTree"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+RUBY_FAKEGEM_GEMSPEC=${RUBY_FAKEGEM_NAME}.gemspec
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="ParseTree extracts the parse tree for a Class or method and returns it as a s-expression."
+HOMEPAGE="http://www.zenspider.com/ZSS/Products/ParseTree/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend '
+ >=dev-ruby/RubyInline-3.10.0
+ >=dev-ruby/sexp_processor-3.0.0'
+ruby_add_bdepend "
+ test? (
+ dev-ruby/hoe
+ dev-ruby/hoe-seattlerb
+ dev-ruby/minitest
+ dev-ruby/ruby2ruby
+ )
+ doc? (
+ dev-ruby/hoe
+ dev-ruby/hoe-seattlerb
+ )"
+
+all_ruby_prepare() {
+ # Fix USE=doc by removing the path that triggers running the tests
+ # and thus building the extensions in the wrong way.
+ sed -i -e '/require_paths/d' Rakefile || die
+}
+
+each_ruby_prepare() {
+ # RubyInline employs a very stupid caching strategy solely based on
+ # the public signatures of methods. Never mind bugs within the C
+ # code... We add a dynamic method name to the parsetree interface
+ # just so that we can guarantee compilation. Fixes #329497.
+ epatch "${FILESDIR}/${PN}-3.0.6-timestamp.patch"
+ sed -i -e "s/TIMESTAMP/$(date +%s)/" lib/parse_tree.rb || die
+
+ # Generate a gemspec file that we can manipulate more easily, and
+ # match RubyInline dependency to our versioning.
+ ruby_fakegem_metadata_gemspec ../metadata ${RUBY_FAKEGEM_GEMSPEC}
+ sed -i -e 's/~> 3.9.0/>= 3.9.0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+src_compile() {
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+ ruby-ng_src_compile
+}
+
+each_ruby_compile() {
+ # The ruby extension uses RubyInline to use C code within Ruby;
+ # since it causes us no little pain, we'll do our best here to
+ # prebuild the extensions.
+
+ INLINEDIR="${PWD}" ${RUBY} -Ilib -rparse_tree -e '' || die "Unable to load ${PN}"
+
+ mkdir lib/inline
+ cp .ruby_inline/*/*$(get_modname) lib/inline/ || die
+}
+
+src_test() {
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+ ruby-ng_src_test
+}
+
+pkg_postinst() {
+ elog "${CATEGORY}/${PN} uses the RubyInline library to build its parser."
+ elog "RubyInline builds loadable extensions at runtime in your home"
+ elog "directory if they are not supplied by the gems."
+ elog ""
+ elog "We are currently providing you with pre-built extensions for"
+ elog "the Ruby implementations you're using. Unfortunately these are"
+ elog "different from version to version, so you might have to"
+ elog "rebuild ${CATEGORY}/${PN} after each update to dev-lang/ruby or"
+ elog "dev-lang/ruby-enterprise."
+}