summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-01-24 15:39:47 +0000
committerHans de Graaff <graaff@gentoo.org>2010-01-24 15:39:47 +0000
commitcd34d160fd7c4c3df1cab691b51a7b9f4a3f715c (patch)
tree2ba6e66269c7abe4dd4ae73cc4ab9c3665b32f08 /dev-ruby/prawn-core
parentBump to ruby-fakegem (was using a precious fakegem-like trick before). (diff)
downloadgentoo-2-cd34d160fd7c4c3df1cab691b51a7b9f4a3f715c.tar.gz
gentoo-2-cd34d160fd7c4c3df1cab691b51a7b9f4a3f715c.tar.bz2
gentoo-2-cd34d160fd7c4c3df1cab691b51a7b9f4a3f715c.zip
Initial import. New dependency of dev-ruby/prawn.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/prawn-core')
-rw-r--r--dev-ruby/prawn-core/ChangeLog10
-rw-r--r--dev-ruby/prawn-core/metadata.xml5
-rw-r--r--dev-ruby/prawn-core/prawn-core-0.7.1.ebuild40
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-ruby/prawn-core/ChangeLog b/dev-ruby/prawn-core/ChangeLog
new file mode 100644
index 000000000000..557112a17091
--- /dev/null
+++ b/dev-ruby/prawn-core/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/prawn-core
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/prawn-core/ChangeLog,v 1.1 2010/01/24 15:39:47 graaff Exp $
+
+*prawn-core-0.7.1 (24 Jan 2010)
+
+ 24 Jan 2010; Hans de Graaff <graaff@gentoo.org> +prawn-core-0.7.1.ebuild,
+ +metadata.xml:
+ Initial import. New dependency of dev-ruby/prawn.
+
diff --git a/dev-ruby/prawn-core/metadata.xml b/dev-ruby/prawn-core/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/prawn-core/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/prawn-core/prawn-core-0.7.1.ebuild b/dev-ruby/prawn-core/prawn-core-0.7.1.ebuild
new file mode 100644
index 000000000000..da9c86fb05f2
--- /dev/null
+++ b/dev-ruby/prawn-core/prawn-core-0.7.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/prawn-core/prawn-core-0.7.1.ebuild,v 1.1 2010/01/24 15:39:47 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="HACKING README"
+
+# ttfunk and pdf-inspector are vendored, and the versions currently
+# there are not identical to the versions we already carry in our
+# tree. To be fixed.
+RUBY_FAKEGEM_EXTRAINSTALL="data vendor"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Fast, Nimble PDF Generation For Ruby"
+HOMEPAGE="http://prawn.majesticseacreature.com/"
+
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+ruby_add_bdepend test "dev-ruby/test-spec dev-ruby/mocha"
+
+# Older versions of prawn install the same files, but in site_ruby
+# which gets found before the newer gem install path that prawn-core
+# uses.
+RDEPEND="!<dev-ruby/prawn-0.7"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples || die "Installing examples failed."
+ fi
+}