summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-07-21 06:16:50 +0000
committerHans de Graaff <graaff@gentoo.org>2013-07-21 06:16:50 +0000
commit7ab2ae8c2415b38ca0c5486a2b4a195b1a482d9a (patch)
tree55756bac5ef967a01d8325a2c66ce43ab31fd227 /dev-ruby/racc
parentCleanup. (diff)
downloadgentoo-2-7ab2ae8c2415b38ca0c5486a2b4a195b1a482d9a.tar.gz
gentoo-2-7ab2ae8c2415b38ca0c5486a2b4a195b1a482d9a.tar.bz2
gentoo-2-7ab2ae8c2415b38ca0c5486a2b4a195b1a482d9a.zip
Cleanup.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/racc')
-rw-r--r--dev-ruby/racc/ChangeLog6
-rw-r--r--dev-ruby/racc/racc-1.4.6-r1.ebuild78
-rw-r--r--dev-ruby/racc/racc-1.4.6.ebuild77
3 files changed, 5 insertions, 156 deletions
diff --git a/dev-ruby/racc/ChangeLog b/dev-ruby/racc/ChangeLog
index 9f73fc9ded93..843b2ce08763 100644
--- a/dev-ruby/racc/ChangeLog
+++ b/dev-ruby/racc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/racc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/ChangeLog,v 1.94 2013/07/07 08:08:54 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/ChangeLog,v 1.95 2013/07/21 06:16:50 graaff Exp $
+
+ 21 Jul 2013; Hans de Graaff <graaff@gentoo.org> -racc-1.4.6.ebuild,
+ -racc-1.4.6-r1.ebuild:
+ Cleanup.
07 Jul 2013; Hans de Graaff <graaff@gentoo.org> racc-1.4.9.ebuild:
Add ruby20 support.
diff --git a/dev-ruby/racc/racc-1.4.6-r1.ebuild b/dev-ruby/racc/racc-1.4.6-r1.ebuild
deleted file mode 100644
index e1b22c87ed78..000000000000
--- a/dev-ruby/racc/racc-1.4.6-r1.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/racc-1.4.6-r1.ebuild,v 1.13 2012/11/06 16:54:47 jer Exp $
-
-EAPI=2
-
-USE_RUBY="ree18 ruby18 ruby19 jruby"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="README.en.rdoc README.ja.rdoc TODO ChangeLog"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A LALR(1) parser generator for Ruby"
-HOMEPAGE="http://www.loveruby.net/en/racc.html"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-IUSE=""
-
-ruby_add_bdepend "dev-ruby/rake test? ( virtual/ruby-test-unit )"
-
-all_ruby_prepare() {
- # for Ruby 1.9.2 compatibility
- sed -i -e '1i $: << "."' Rakefile || die
-
- sed -i -e '/tasks\/email/s:^:#:' Rakefile || die "rakefile fix failed"
- sed -i -e '/prerequisites/s:^:#:' tasks/test.rb || die "test task fix failed"
- sed -i -e 's|/tmp/out|${TMPDIR:-/tmp}/out|' test/helper.rb || die "tests fix failed"
- sed -i -e '/git ls-files/d' tasks/gem.rb || die
-
- epatch "${FILESDIR}"/${P}-test-unit.patch
-}
-
-each_ruby_prepare() {
- if [[ $(basename ${RUBY}) == "ruby18" ]]; then
- sed -i -e 's:ruby/ruby.h:ruby.h:' \
- ext/racc/cparse/cparse.c || die
- fi
-}
-
-each_ruby_compile() {
- case ${RUBY} in
- *jruby)
- einfo "Under JRuby, racc cannot use the shared object parser, so instead"
- einfo "you have to rely on the pure Ruby implementation."
- ;;
- *)
- ${RUBY} -S rake build || die "build failed"
- # Copy over the file here so that we don't have to do
- # special ruby install for JRuby and the other
- # implementations.
- cp -l ext/racc/cparse/cparse$(get_modname) lib/racc/cparse$(get_modname) || die
- ;;
- esac
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *jruby)
- ewarn "Using JRuby 1.5.2 the tests are currently badly broken,"
- ewarn "so they are disabled until a new racc or a new JRuby is"
- ewarn "released."
- ;;
- *)
- each_fakegem_test
- ;;
- esac
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- docinto examples
- dodoc sample/* || die
-}
diff --git a/dev-ruby/racc/racc-1.4.6.ebuild b/dev-ruby/racc/racc-1.4.6.ebuild
deleted file mode 100644
index bb5e61849e55..000000000000
--- a/dev-ruby/racc/racc-1.4.6.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/racc-1.4.6.ebuild,v 1.18 2012/10/27 18:15:08 armin76 Exp $
-
-EAPI=2
-
-USE_RUBY="ree18 ruby18 jruby"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="README.en.rdoc README.ja.rdoc TODO ChangeLog"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A LALR(1) parser generator for Ruby"
-HOMEPAGE="http://www.loveruby.net/en/racc.html"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-
-KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
-IUSE=""
-
-ruby_add_bdepend "dev-ruby/rake test? ( virtual/ruby-test-unit )"
-
-all_ruby_prepare() {
- # for Ruby 1.9.2 compatibility
- sed -i -e '1i $: << "."' Rakefile || die
-
- sed -i -e '/tasks\/email/s:^:#:' Rakefile || die "rakefile fix failed"
- sed -i -e '/prerequisites/s:^:#:' tasks/test.rb || die "test task fix failed"
- sed -i -e 's|/tmp/out|${TMPDIR:-/tmp}/out|' test/helper.rb || die "tests fix failed"
-
- epatch "${FILESDIR}"/${P}-test-unit.patch
-}
-
-each_ruby_prepare() {
- if [[ $(basename ${RUBY}) == "ruby18" ]]; then
- sed -i -e 's:ruby/ruby.h:ruby.h:' \
- ext/racc/cparse/cparse.c || die
- fi
-}
-
-each_ruby_compile() {
- case ${RUBY} in
- *jruby)
- einfo "Under JRuby, racc cannot use the shared object parser, so instead"
- einfo "you have to rely on the pure Ruby implementation."
- ;;
- *)
- ${RUBY} -S rake build || die "build failed"
- # Copy over the file here so that we don't have to do
- # special ruby install for JRuby and the other
- # implementations.
- cp -l ext/racc/cparse/cparse$(get_modname) lib/racc/cparse$(get_modname) || die
- ;;
- esac
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *jruby)
- ewarn "Using JRuby 1.5.2 the tests are currently badly broken,"
- ewarn "so they are disabled until a new racc or a new JRuby is"
- ewarn "released."
- ;;
- *)
- each_fakegem_test
- ;;
- esac
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- docinto examples
- dodoc sample/* || die
-}