summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-08-17 08:54:13 +0000
committerHans de Graaff <graaff@gentoo.org>2011-08-17 08:54:13 +0000
commitf1fb9ccaf65e804efb222a8a30e2e5a0f26f37c3 (patch)
tree370b5fa6518040b9226d719d732161849924afcc /dev-ruby/rails
parentAdd minimum dep on texlive-latex, bug #379285 (diff)
downloadgentoo-2-f1fb9ccaf65e804efb222a8a30e2e5a0f26f37c3.tar.gz
gentoo-2-f1fb9ccaf65e804efb222a8a30e2e5a0f26f37c3.tar.bz2
gentoo-2-f1fb9ccaf65e804efb222a8a30e2e5a0f26f37c3.zip
Version bump.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rails')
-rw-r--r--dev-ruby/rails/ChangeLog7
-rw-r--r--dev-ruby/rails/rails-2.3.14.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/dev-ruby/rails/ChangeLog b/dev-ruby/rails/ChangeLog
index 321b84fc87af..247486a6f3f1 100644
--- a/dev-ruby/rails/ChangeLog
+++ b/dev-ruby/rails/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rails
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.198 2011/08/07 19:03:45 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.199 2011/08/17 08:54:13 graaff Exp $
+
+*rails-2.3.14 (17 Aug 2011)
+
+ 17 Aug 2011; Hans de Graaff <graaff@gentoo.org> +rails-2.3.14.ebuild:
+ Version bump.
07 Aug 2011; Raúl Porcel <armin76@gentoo.org> rails-3.0.9.ebuild:
Add ~ia64/~sparc wrt #351835
diff --git a/dev-ruby/rails/rails-2.3.14.ebuild b/dev-ruby/rails/rails-2.3.14.ebuild
new file mode 100644
index 000000000000..e4b81cc327de
--- /dev/null
+++ b/dev-ruby/rails/rails-2.3.14.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-2.3.14.ebuild,v 1.1 2011/08/17 08:54:13 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_EXTRAINSTALL="builtin configs doc dispatches environments fresh_rakefile helpers html README"
+RUBY_FAKEGEM_EXTRADOC="README CHANGELOG"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+# gem lacks tests
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="ruby on rails is a web-application and persistance framework"
+HOMEPAGE="http://www.rubyonrails.org"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+
+IUSE=""
+
+RDEPEND=">=app-admin/eselect-rails-0.15"
+
+ruby_add_rdepend ">=dev-ruby/rake-0.8.3
+ dev-ruby/rdoc
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activeresource-${PV}
+ ~dev-ruby/activesupport-${PV}
+ ~dev-ruby/actionmailer-${PV}
+ ~dev-ruby/actionpack-${PV}"
+ruby_add_bdepend "doc? ( dev-ruby/redcloth )"
+
+all_ruby_prepare() {
+ sed -i -e '/horo/d' Rakefile || die "Could not remove reference to unavailable documentation template."
+
+ # Create the documentation that we create on the fly in a separate
+ # directory, since we need to install the doc directory for the
+ # rails script.
+ sed -i -e "s/rdoc_dir = 'doc'/rdoc_dir = 'rdoc'/" Rakefile || die
+
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ ruby_fakegem_binwrapper rails rails-${PV}
+
+ if use doc; then
+ pushd rdoc
+ docinto api
+ dohtml -r *
+ popd
+ fi
+}
+
+pkg_postinst() {
+ elog "To select between slots of rails, use:"
+ elog "\teselect rails"
+
+ eselect rails update
+}
+
+pkg_postrm() {
+ eselect rails update
+}